Results 1 to 4 of 4

powerbond install problem

This is a discussion on powerbond install problem within the Internal Engine forums, part of the LSx Technical Help Section category; I am trying to install a powerbond pulley on 6.0l tsp short block with a stock ls1 crank but the ...

  1. #1
    Junior Member
    Join Date
    Aug 2005

    hugger orange

    powerbond install problem

    I am trying to install a powerbond pulley on 6.0l tsp short block with a stock ls1 crank but the damn thing wont go on far enough to line up with the alterantor and water pump. It is no where near touching anything (crank gear) I am afraid I am about to pull the threads out of the crank. any help or advice is appreciated!

  2. #2
    Jesus died to save you! Killer_bluebird's Avatar
    Join Date
    Aug 2005
    North Olmsted, OH

    Navy Blue Metallic
    2000 Camaro Z28

    It took quite a bit of muscle to get mine in too. I doubt that you will pull the threads off the crank. I used one of those install tools and I tapered the thick metal washer from the amount of strength I had to use to get mine in. The second time around it wasn't as bad but it still needed quite a bit of muscle. I guess the good thing is that you won't have to worry about it comming off!
    Last edited by Killer_bluebird; 04-10-2007 at 03:43 PM.
    2000 NBM Camaro Z28
    SLP Lid & K&N, AHR Headers + 3" catted Y and Mangaflow, !EGR, !AIR, BMR CM STB, ST Front 35mm and Hellwig Adj. Rear 22mm Swaybar, Adj. Rod/Rod PHB, Koni SA's, Ground Control Springs & Adj. Ride height, and HPTuners.

  3. #3
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    St Thomas, PA

    1998 Trans Am

    Thow it in the oven at 250 degree's for an hour... Might help expand it some...

  4. #4
    Member va2001ss's Avatar
    Join Date
    Aug 2005
    Northern Virginia
    2001 Black SS #5228

    Oven trick worked for me as well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SLP Airlid Install Problem
    By metalgoldta in forum General Help
    Replies: 6
    Last Post: 01-25-2007, 11:52 AM
  2. Kook's LTs install problem
    By bigcraig987 in forum External Engine
    Replies: 17
    Last Post: 01-05-2007, 04:03 PM
  3. Problem with new clutch install, need help
    By FuriousGeorge in forum Manual Transmission
    Replies: 0
    Last Post: 04-27-2006, 06:17 AM
  4. 92 Camaro RS Transmission Install Problem
    By Bigrob92rs in forum Camaro / SS
    Replies: 0
    Last Post: 04-06-2006, 04:32 PM
  5. big problem with header install...NEED HELP FAST!!!
    By groundpoundinlt1 in forum General Help
    Replies: 20
    Last Post: 02-12-2006, 04:06 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts