Page 4 of 4 FirstFirst 1234
Results 61 to 65 of 65

pics of Whiteboycntdnce's H/C/I install n progress

This is a discussion on pics of Whiteboycntdnce's H/C/I install n progress within the Internal Engine forums, part of the LSx Technical Help Section category; Originally Posted by Frost I'd have to redo the math but just a hair under 11:1..... Tim those heads did ...

  1. #61
    Quote Originally Posted by Frost View Post
    I'd have to redo the math but just a hair under 11:1..... Tim those heads did end up being milled to 62cc right?
    It could have been much better than that. Had you left the carbon on the pistons the compression would have been bumped up a good bit, and it would have been without any valve clearance issues

  2. #62
    Junior Member wantedz's Avatar
    Join Date
    Dec 2007
    Location
    emporia va
    Posts
    13

    silver
    2000 B4C

    Yeah yeah we always get blamed for something along the way.LOL. You got to put that clutch in though, I'm ready to see some numbers.

  3. #63
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    Clutch is in... Cut-out is going in today. I'm planning on going out to PAS tomorrow around noon or so to hook up w/ Steve so we can plug it up and see what the issue is.

  4. #64
    Junior Member wantedz's Avatar
    Join Date
    Dec 2007
    Location
    emporia va
    Posts
    13

    silver
    2000 B4C

    Nice to see you the other day. How about that ride in the Z was that funny or what. LOL HAHA. Show off and what do you get.

  5. #65
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    hahaha jesus dude... Oh well,could have been worse... Dude could have been a real dick. I got the cutout working so now the car sounds like it should!

Page 4 of 4 FirstFirst 1234

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A few pics of my working progress..
    By foxman92 in forum Member's Rides
    Replies: 15
    Last Post: 08-15-2009, 04:24 PM
  2. Progress of my head install
    By TheKitchenSink in forum Internal Engine
    Replies: 54
    Last Post: 03-28-2008, 07:23 PM
  3. Progress pics on the CME setup
    By Y2KPewterSS in forum Appearance Section
    Replies: 20
    Last Post: 08-11-2007, 09:41 PM
  4. 12" box INSTALL -- progress PICS (partial rear well box)
    By fredmr85 in forum Stereo and Electronics
    Replies: 14
    Last Post: 07-01-2007, 07:57 PM
  5. INSTALL progress pics -- rear well box for 12" -- PICS
    By fredmr85 in forum Stereo and Electronics
    Replies: 0
    Last Post: 05-28-2007, 01:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •