Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 65

pics of Whiteboycntdnce's H/C/I install n progress

This is a discussion on pics of Whiteboycntdnce's H/C/I install n progress within the Internal Engine forums, part of the LSx Technical Help Section category; I gotta tell yall... That fast 90 TB is junk, ... I just put a pretty stiff spring on it ...

  1. #41
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    I gotta tell yall... That fast 90 TB is junk, ... I just put a pretty stiff spring on it to make it close better and the RPMs are still lingering high after you left off the gas... I dont know what to do =[ But I do enjoy listening to it idle lol

  2. #42
    2 SS's are better than 1 Jays00ss's Avatar
    Join Date
    Jun 2007
    Location
    Lathrop, Missouri
    Posts
    2,479

    NBM / Silver
    00 SS / 71 SS Elcamino

    Quote Originally Posted by Whiteboycntdnce View Post
    I gotta tell yall... That fast 90 TB is junk, ... I just put a pretty stiff spring on it to make it close better and the RPMs are still lingering high after you left off the gas... I dont know what to do =[ But I do enjoy listening to it idle lol
    Thats why I went with a PTM tb. Texas Speed highly recomended it and it is a very nice piece. It was also cheaper than the FAST. Even My tuner really liked it and is going to buy one.
    2000 SS Camaro Heads, Large cam, Fast 90, 9"w/430's and locker, yada yada yada... you get the picture

    1971 SS ElCamino 402 Big Block 550HP

    2006 Silverado 2500HD 496 cubic inches of pure muscle

  3. #43
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    I just got off the phone with a tech guy from Comp/FAST and basicaly he said try to the return spring and get it tuned... Steve... He said something may not be pulsing right? I dunno... I told him it's a real slow return to idle and he said it could be the fact that car hasnt been fully tuned yet... sound right? ICA... something I dont remember

  4. #44
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    SCHWING! Click for full size

    seriously, though-this is a cool thread. It's rare to see sponsors post up stuff they're working on.

  5. #45
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    Quote Originally Posted by Whiteboycntdnce View Post
    I just got off the phone with a tech guy from Comp/FAST and basicaly he said try to the return spring and get it tuned... Steve... He said something may not be pulsing right? I dunno... I told him it's a real slow return to idle and he said it could be the fact that car hasnt been fully tuned yet... sound right? ICA... something I dont remember
    Yeah he's tapdancing around the fact that that thing is a turd. It's not fully tuned, but no tuning is going to have any effect on that sticking throttle body... Your IAC counts are within range as the car has no problem starting or idling without swing, so they are not too high, and it doesn't lose control of idle headed up, so they are not too low. Ask him to explain the myriad of threads about that TB sticking... It's not the tuning, when it sticks and the RPMs hang, a pat of the foot makes it fall back to idle immeadiately. Tell them to man up and fix it and stop beating around the bush.

    This is why I hate the phone, when I am standing in front of someone with a defective part they are always more willing to work with me; especially when I uhhh...... INSIST.



    Quote Originally Posted by third_shift|studios View Post
    SCHWING! Click for full size

    seriously, though-this is a cool thread. It's rare to see sponsors post up stuff they're working on.

    Just trying to add a lil content.

  6. #46
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    He said they know about the issue and offered to send me to the warranty department, guess i should call back and see how long it's going to take those fools to fix/replace it

  7. #47
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    Quote Originally Posted by Whiteboycntdnce View Post
    He said they know about the issue and offered to send me to the warranty department, guess i should call back and see how long it's going to take those fools to fix/replace it
    If I were you, and I had the $$, I'd buy a NW TB and sell the replaced/warrantied FAST TB when I got it back. Sorry to say. I should have paid more attention to your list of items along the way, I would have mentioned, so this is partly my fault.

  8. #48
    doesn'tplaywellwithothers superchargedblackgto's Avatar
    Join Date
    Jan 2007
    Location
    Mayberry....(Indiana)
    Posts
    1,634

    Black
    2004 GTO

    Quote Originally Posted by Whiteboycntdnce View Post
    I gotta tell yall... That fast 90 TB is junk, ... I just put a pretty stiff spring on it to make it close better and the RPMs are still lingering high after you left off the gas... I dont know what to do =[ But I do enjoy listening to it idle lol
    I have a Fast 90 tb on my car, it stuck too, I have a vid, when I first put it on the car.......I sent it back to them they worked on it.....was good for about 1 yr, and it is sticking again......now I don't have a catch can on my car and there was oil in the tb I took some carb cleaner to it and it quit sticking however I have noticed it still sticks periodically and I know its time to clean it up after that it works better...........IMHO FAST 90=JUNK.....but I own it and clean it seems to work OK
    Brad

  9. #49
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    If everything works out the way I'm hoping for, I should be ordering a NW or other TB... Anyone run the Holley or Edelbrock 90's?

  10. #50
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    I'd stay with what we know works personally... NW has changed his a bit too, got rid os that set-screw for the blae adjustment and has a full screw through with a spring to hold it's settings. Very nice.
    Last edited by Frost; 03-29-2008 at 07:10 AM.

  11. #51
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    Assuming MW is suppose to be NW It's still cheaper than the FAST so I'll probably roll with it. But didnt you saybefore that you heard people saying their NW was sticking some too?

  12. #52
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    No, but I used to hate that steel set-screw that set the blade angle because it would get loose. That is better now.

  13. #53
    Junior Member wantedz's Avatar
    Join Date
    Dec 2007
    Location
    emporia va
    Posts
    13

    silver
    2000 B4C

    I'm glad to know none of this falls back on the wrench turner. That thing was sticking on me a little on the way up, but never hung until i got it to his house. I thought it made me look so bad.

  14. #54
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    Nah the wrench turner is clear lol ... THIS TIME

  15. #55
    I need some money huggerls1's Avatar
    Join Date
    Feb 2007
    Location
    chandler az
    Age
    33
    Posts
    165

    hugger orange
    1999 camaro ss

    so what was the total of all the parts purchased if you dont mind me asking. 5 more months and i might be doing the same thing.....

  16. #56
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    2500 for heads, about 500 for cam, ... oil pump/lifters/rods/fuel injectors/fuel pump all somewhere around 4500

  17. #57
    Awaiting Activation
    Join Date
    Sep 2007
    Location
    Philly+Glenmoore, Pa
    Age
    28
    Posts
    4,704

    Pewter Metallic
    2002 Trans Am WS6 M6 D1SC

    what numbers are we talkin about here? Im sure over 400 but was it dynoed?

  18. #58
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    Hasnt been on the rollers yet... (By the way I forgot the fast 90 intake/TB) But i've been hearing 470+ off the bottle.

  19. #59
    Awaiting Activation
    Join Date
    Sep 2007
    Location
    Philly+Glenmoore, Pa
    Age
    28
    Posts
    4,704

    Pewter Metallic
    2002 Trans Am WS6 M6 D1SC

    Quote Originally Posted by Whiteboycntdnce View Post
    Hasnt been on the rollers yet... (By the way I forgot the fast 90 intake/TB) But i've been hearing 470+ off the bottle.
    Sounds good! Im looking to similar numbers down by the end of this summer if I can.

  20. #60
    Member Whiteboycntdnce's Avatar
    Join Date
    Mar 2007
    Location
    Virginia
    Posts
    190

    Black
    2000 / SS

    Everyone's "timid" (understandably) about giving me number assumptions, but I have faith in the people who I've been working closely with... I wouldnt mind seeing a total of (around) 600 whp on the bottle.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A few pics of my working progress..
    By foxman92 in forum Member's Rides
    Replies: 15
    Last Post: 08-15-2009, 04:24 PM
  2. Progress of my head install
    By TheKitchenSink in forum Internal Engine
    Replies: 54
    Last Post: 03-28-2008, 07:23 PM
  3. Progress pics on the CME setup
    By Y2KPewterSS in forum Appearance Section
    Replies: 20
    Last Post: 08-11-2007, 09:41 PM
  4. 12" box INSTALL -- progress PICS (partial rear well box)
    By fredmr85 in forum Stereo and Electronics
    Replies: 14
    Last Post: 07-01-2007, 07:57 PM
  5. INSTALL progress pics -- rear well box for 12" -- PICS
    By fredmr85 in forum Stereo and Electronics
    Replies: 0
    Last Post: 05-28-2007, 01:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •