Results 1 to 9 of 9

P0300 Random Misfire #2 and #7

This is a discussion on P0300 Random Misfire #2 and #7 within the Internal Engine forums, part of the LSx Technical Help Section category; '02 Camaro Z28 has been running super since I bought it. Has K&N FIPK and Corsa Cat Back exhaust. On ...

  1. #1
    Junior Member
    Join Date
    Jun 2007
    Location
    NH
    Posts
    6

    Red
    2002 Camaro Z28 35th

    P0300 Random Misfire #2 and #7

    '02 Camaro Z28 has been running super since I bought it. Has K&N FIPK and Corsa Cat Back exhaust. On the way to the shop for yearly inspection (can you believe it), SES light starts blinking, engine runs rough, exhaust smell. Code shows #7 lots of misfires, #2 half as much. Mechanic has now gone through most of the diagnostics - replace gas filter, clean all injectors, swap injectors, replace #2 injector with reman, swap plugs, swap coils, replace Crank Position Sensor and did two relearns. He hasn't done a smoke test for intake leaks or a compression test because two cylinders started acting up at the same time. Searching Archives on different forums has turned up both Vacuum leak behind intake manifold (although I don't think this would be specific to two cylinders) and weak/broken valve springs. Does anybody have a clue as to what might be going on? It seems I would have a better chance of winning the lottery than to have a cylinder specific item like valve springs, coil, etc. on both cylinders fail at exactly the same time. Is it possible that a sensor (O2 or MAF) could cause multiple cylinder specific problems? Thanks for any replies.
    Last edited by skyking; 06-20-2007 at 11:43 AM.

  2. #2
    Thou Shalt Drag slowagon's Avatar
    Join Date
    Apr 2007
    Location
    Travis AFB
    Age
    35
    Posts
    37

    Hugger Orange
    1999 Z28

    Possibly coil packs? Does it idle rough?

  3. #3
    Junior Member
    Join Date
    Jun 2007
    Location
    NH
    Posts
    6

    Red
    2002 Camaro Z28 35th

    You can barely tell it's misfiring at idle, it's not that bad and mechanic tried swapping coils #2 and #4, but it's bad enough to make the SES blink.

  4. #4
    Thou Shalt Drag slowagon's Avatar
    Join Date
    Apr 2007
    Location
    Travis AFB
    Age
    35
    Posts
    37

    Hugger Orange
    1999 Z28

    If it's running rich it could be a dirty maf. How many miles are on this car?

  5. #5
    Junior Member
    Join Date
    Jun 2007
    Location
    NH
    Posts
    6

    Red
    2002 Camaro Z28 35th

    It has just under 28k. Only drive it in good/warm weather up here in NH.

  6. #6
    Thou Shalt Drag slowagon's Avatar
    Join Date
    Apr 2007
    Location
    Travis AFB
    Age
    35
    Posts
    37

    Hugger Orange
    1999 Z28

    Did you see this thread, it might help. He's expriencing the same problem.
    P0300 code random misfire...

  7. #7
    Junior Member
    Join Date
    Jun 2007
    Location
    NH
    Posts
    6

    Red
    2002 Camaro Z28 35th

    Hey thanks for the input, I just added my tale of woe to their thread, maybe someone has a clue why TWO cylinders started misfiring at the same time.

  8. #8
    Junior Member
    Join Date
    Jun 2007
    Location
    NH
    Posts
    6

    Red
    2002 Camaro Z28 35th

    Thanks everyone for the ideas. Turns out the mechanic was only diagnosing #2 because it was easy to get to. Problem turned out to be a bad plug in #7 (only) so we are good to go. Misfires in #7 were backfeeding into #2 (next in firing order) so it looked like there was a problem with #2 as well. These were Bosch single tip platinums I put in only 10k miles ago. I have now replaced them with Delco Iridiums.
    Last edited by skyking; 07-03-2007 at 11:09 AM.

  9. #9
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    check your cats .....the nearest dealership should replace em....mostly everyone has this problem with their "mildly" stock fbody

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0300 misfire code...help:(
    By Lotapwr in forum General Help
    Replies: 7
    Last Post: 05-02-2013, 08:19 PM
  2. Intermintent P0300 random misfire
    By eteller in forum General Help
    Replies: 25
    Last Post: 02-10-2013, 05:39 PM
  3. Help: Random Misfire P0300 Help Needed
    By fred007 in forum General Help
    Replies: 5
    Last Post: 07-18-2012, 10:46 AM
  4. P0300 code random misfire...
    By MagicMan in forum General Help
    Replies: 87
    Last Post: 07-31-2009, 02:27 PM
  5. Need help with P0300 misfire
    By Doc99SS in forum Computer & Tuning
    Replies: 2
    Last Post: 10-24-2005, 08:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •