Results 1 to 5 of 5

oil pressure low? need opinions..

This is a discussion on oil pressure low? need opinions.. within the Internal Engine forums, part of the LSx Technical Help Section category; Ok so yesterday I had the car completley back together fresh oil in the engine new ac delco oil filter ...

  1. #1
    Member MachWon's Avatar
    Join Date
    May 2009
    Location
    Bavaria, Germany
    Posts
    104

    pewter
    99 vette

    oil pressure low? need opinions..

    Ok so yesterday I had the car completley back together fresh oil in the engine new ac delco oil filter with 7 quarts of mobil 5-W30 synthetic. Turned the key and it fired right up with no hesitation and suprisingly idled very well with the new cam on a stock tune. While I had the engine apart I replaced the factory oil pump with a ported ls6 oil pump. I noticed the oil pressure was very low once I started it up it was hanging around 7 psi, before the build on the stock oil pump i had 40lbs at every rpm, now I realize the new lifters needed time to pump up and all so I waited and it finally climbed to about 15-17 at idle now and climbs to about 41 once I step on the gas, but my factory oil pump had better pressure, again this is a new ported ls6 oil pump. Any ideas? thanks

  2. #2
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    Are you sure you have the pickup tube and O ring set in the pump good, and you didn't tear the O ring? I wouldn't want any less than 25 psi

  3. #3
    Member MachWon's Avatar
    Join Date
    May 2009
    Location
    Bavaria, Germany
    Posts
    104

    pewter
    99 vette

    Yes I am positive the o-ring is good and seated properly. I just can't figure it out. Anyway I drove it on the autobahn for 3 hours today at speeds of 100-165 mph the entire way and it ran like a top. I think it's ok. I read the my corvette owners manual and to my suprise it said that a reading as low as 6 pounds can be considered normal when the engine is hot and using thin oil. But normal pressure should be between 20-40. Once I am over 1500 rpms I have around 25 plus and from there it climbs higher as the rpms climb but at idle I have seen it read as low as 11. I think I will just order a new sending unit for it and see what happens there is a possiblity it could be going out or the gauge isnt reading properly after all I did have the engine torn down and theres a chance I could have screwed up the sending unit.

  4. #4
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    It wouldn't hurt to run an aftermarket gauge and sending unit with your stock one just for backup to be sure... I envy you, I'd love to beable to open my car up and see what it would do without getting locked up for it lol

  5. #5
    Member crossbredfoxbody's Avatar
    Join Date
    Jan 2010
    Location
    First In Flight
    Age
    35
    Posts
    160

    white
    83 mustang coupe

    Ive heard of people having problems with caddie lifters with a higher flow pump.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil Pressure opinions wanted
    By transamdave in forum Firebird / WS6
    Replies: 27
    Last Post: 06-09-2014, 10:25 AM
  2. Your Opinions
    By 98MustGT in forum Political / Debate Forum
    Replies: 1
    Last Post: 09-26-2008, 11:11 PM
  3. Replies: 3
    Last Post: 04-01-2006, 04:59 PM
  4. Looking for gauges! nitrous pressure, fuel pressure!
    By texasss in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 10-29-2005, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •