Results 1 to 11 of 11

oil leak

This is a discussion on oil leak within the Internal Engine forums, part of the LSx Technical Help Section category; ive ruled out what i thought was the rear main seal leaking, changed that recently. ive noticed oil dripping closer ...

  1. #1
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    Angry oil leak

    ive ruled out what i thought was the rear main seal leaking, changed that recently. ive noticed oil dripping closer to the top of the engine, could it be the oil sending unit in the valley leaking? still no defined drip location, by the time it starts leaking it sprays all over and makes it very hard to tell an exact location. any input would be great.

  2. #2
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    I just sealed a leak on my 99 camaro. It was the oil cooler block off plate just above the oil filter. I just took the cover apart and used aicraft form-a-gasket cement and glued it all back together. Here is a link to a truck forum talking about the same thing;

    http://www.gm-trucks.com/forums/inde...52&hl=oil+leak

  3. #3
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    ive heard of that before, ill have to look again, i didnt notice any leaking from there, but i did just have it cleaned so ill check it again tomarow.

  4. #4
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    that side of the engine is dry, is it possible the oil sending unit is leaking? it seems to be dripping around the inspection plate by the starter, and even dripping into the bell housing. im going to replace all my gaskets and im swapping manifolds anyway, so i might get a better look at it once the manifold is off. the spray is so bad it seems inpossible to find an exact point of leaking. i figure if its not the rear main, and the drivers side is dry, that only leaves a few seals to worry about. any imput?

  5. #5
    Junior Member
    Join Date
    Aug 2008
    Location
    Kingwood Texas
    Posts
    9
    I have that same issue on my '00 right now. Sounds like the same exact location too.

    I recently had my tranny out to change the converter so I changed the rear seal and cleaned the hell out of everything. Like you, I found that it's not the rear seal.

    So, while I was changing the intake last week I changed the oil sending unit. But from looking with the intak off, it wasn't that. I also pulled out the cam position sensor, cleaned the o-ring, and put it back. My leak has slowed but is still there. I wish I'd have had the patience to go back to the parts store and get a new O-Ring

    I'm convinced that the cam sensor/o-ring is the culprit. I didn't spend enough time cleaning that area out. It was really nasty when I removed it and probably had a pile of gook still on the block when I shoved it back in.

    I don't see any way of getting to it without removing the intake again.

  6. #6
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    sure does sound like the same thing, im doing the swap next weekend, only time i can do it, so ill let you know what i find. i sure hope thats it......

  7. #7
    Junior Member
    Join Date
    Aug 2008
    Location
    Kingwood Texas
    Posts
    9
    What ever came of this?

  8. #8
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    ha, well did the swap, found a bunch of oil under the manifold. the knock sensor oil seal was bad, so oil was flooding up the valley port for the sensor, replaced all gaskets and seals and thought we were good. after the swap we put it on a lift to run some wires and hook up a sensor, and low and behold, its still leaking!! not sure whats going on....

  9. #9
    My Neighbors Hate Me!!! lvbroham1's Avatar
    Join Date
    Jun 2006
    Location
    Ft. Lee, Virginia
    Posts
    374

    Artic White
    2001 Chevy Camaro SS

    I think the next step would be to replace your rear cover gasket and see if that fixes it. That's the only other gasket I can think of that would be causing that problem back there.

  10. #10
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    rear cover gasket?

  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Quote Originally Posted by sutie View Post
    rear cover gasket?
    I think he is talking about the rear manifold gasket. Did you get all the old gasket material off the block when you swapped manifolds? I think our cars have a cover on the top of the motor at the back of the manifold. I think I remember my tuner talking about this same cover when I take my car back for him to find out what cam I have.
    Last edited by cammed goat; 10-25-2009 at 05:37 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: OIL Leak!!!
    By joedude02 in forum General Help
    Replies: 7
    Last Post: 12-05-2010, 08:59 AM
  2. Serious oil leak
    By Eagle in forum Internal Engine
    Replies: 0
    Last Post: 09-28-2007, 05:54 AM
  3. ttop leak, hatch leak, and window motor problems
    By ATCharming in forum General Help
    Replies: 41
    Last Post: 07-23-2007, 03:30 AM
  4. how serious is PS leak?
    By 02WS6dream in forum General Help
    Replies: 1
    Last Post: 10-16-2006, 05:44 AM
  5. Leak #1 QB?
    By BadBlueBird* in forum Almost Anything Goes
    Replies: 0
    Last Post: 09-18-2006, 07:46 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •