Results 1 to 12 of 12

No radiator pressure???

This is a discussion on No radiator pressure??? within the Internal Engine forums, part of the LSx Technical Help Section category; Hi Everyone, I went and looked at an 05' GTO today with a newly rebuilt motor with a new cam ...

  1. #1
    Member rappin_ernie's Avatar
    Join Date
    May 2010
    Location
    Warminster
    Posts
    136
    2000 Camaro z28

    No radiator pressure???

    Hi Everyone,

    I went and looked at an 05' GTO today with a newly rebuilt motor with a new cam and springs. It ran and sounded great, however when looking over the car, I noticed even after running for 30 minutes, the radiator cap was cold. I slowly twisted and no hissing, so I pulled it and there was no pressure and antifreeze was barely warm. This is with the engine running keep in mind.

    It doesn't overheat and the temp gauge is a little over a 1/4 after 20-30 mins of small test drive and idling.

    Any ideas? The AF was not oily and I couldn't find any leaks.

    Thank you all,

    Mike

  2. #2
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Depending on the outdoor temp, and the tstat in the car, it's possible.

  3. #3
    Member rappin_ernie's Avatar
    Join Date
    May 2010
    Location
    Warminster
    Posts
    136
    2000 Camaro z28

    Quote Originally Posted by Knight View Post
    Depending on the outdoor temp, and the tstat in the car, it's possible.
    I think that may be it, a 160 themostat. I'm just nervous because I'm putting down a lot of money. I will be going back friday and hopefully bring it home!

  4. #4
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Post pics if you do!

  5. #5
    Member rappin_ernie's Avatar
    Join Date
    May 2010
    Location
    Warminster
    Posts
    136
    2000 Camaro z28

    Well I picked her up last friday and have about 300 miles on her so far and shes running like a champ. Here are some pics of the car, I know they suck but it was pouring outside all weekend so I only got garage shots. I will post better ones when I get a chance to wash and get a wider shot.








  6. #6
    Member initechpeter's Avatar
    Join Date
    Apr 2012
    Location
    Iowa
    Posts
    207

    2002 Trans Am WS6 - Red
    2013 Chevy Traverse LTZ

    Nice car.

  7. #7
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified


  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Congrats!

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    sure you weren't grabbing the overflow lid? The radiator cap is under the shroud if memory serves me correctly. The overflow cap is the yellow one.

  10. #10
    Member rappin_ernie's Avatar
    Join Date
    May 2010
    Location
    Warminster
    Posts
    136
    2000 Camaro z28

    It is the chrome chrome cap under the shroud

    I took some better pics today...






  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Could be fine, but I would pressure check the ratiator cap just to be safe. Nice goat Mike.

  12. #12
    Member rappin_ernie's Avatar
    Join Date
    May 2010
    Location
    Warminster
    Posts
    136
    2000 Camaro z28

    Quote Originally Posted by cammed goat View Post
    Could be fine, but I would pressure check the ratiator cap just to be safe. Nice goat Mike.
    Thank you sir, yours as well!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Boiling sound at radiator, radiator cap blowin off
    By lanprat in forum External Engine
    Replies: 7
    Last Post: 08-05-2012, 05:29 PM
  2. Griffin radiator install, stand up radiator install
    By 02Sweet in forum External Engine
    Replies: 12
    Last Post: 06-03-2012, 06:00 PM
  3. Replies: 0
    Last Post: 04-03-2007, 10:20 AM
  4. Looking for gauges! nitrous pressure, fuel pressure!
    By texasss in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 10-29-2005, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •