Results 1 to 13 of 13

New Scorpion Performance Roller Rockers?

This is a discussion on New Scorpion Performance Roller Rockers? within the Internal Engine forums, part of the LSx Technical Help Section category; Anyone have them installed yet? Can you give me some input on how you like them? Any gains at all? ...

  1. #1
    Member Sunset T/A's Avatar
    Join Date
    Oct 2005
    Location
    Spring, TX
    Age
    66
    Posts
    285

    Sunset Orange
    2002 TransAm

    New Scorpion Performance Roller Rockers?

    Anyone have them installed yet? Can you give me some input on how you like them? Any gains at all? Do you have to change valve springs on a stock motor? Thanks.
    2002 Sunset Orange TransAm 6 spd.
    http://www.mustangmods.com/data/1327/dadsigpic2.jpg

  2. #2
    Member
    Join Date
    Oct 2005
    Location
    RI
    Posts
    165

    Mag Red
    2002 Vette

    A guy on Corvetteforum just had a huge problem with them. I would tread carefully until he finds out what happened. Looks like he may have had a setup issue, but at this point there is no word on what happened.

  3. #3

  4. #4
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    I looked at those pics and to me it sounds like someone didn't check their pushrod lengths.......dont know if I would go so far as to call them crap right now...may be more user error on that particular install......

  5. #5
    Member
    Join Date
    Oct 2005
    Location
    RI
    Posts
    165

    Mag Red
    2002 Vette

    If it happened on start-up I would tend to agree, but he had some miles on it. It is FI so I can only think it ran good but he was floating the valves and the rockers got pounded. That said, the fracture surface on the aluminum doesn't look like an extrusion, more like a casting.

  6. #6
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    Quote Originally Posted by cailey37 View Post
    I looked at those pics and to me it sounds like someone didn't check their pushrod lengths.......dont know if I would go so far as to call them crap right now...may be more user error on that particular install......

    read the thread. he said he had 8000-9000 miles on them. pushrod length, piston to valve clearance issues, etc... would have shown up alot sooner.

  7. #7
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    Quote Originally Posted by mrr23 View Post
    read the thread. he said he had 8000-9000 miles on them. pushrod length, piston to valve clearance issues, etc... would have shown up alot sooner.
    Read the thread....he didn't even know what ratio he had......trust me.....if the pushrods were just a little off it could of made that damage over time......could of made it 8000 miles but to have every last one of them do the same thing........sounds like an easy answer.....but hey.....wont be the first time I'm wrong...
    Last edited by cailey37; 07-17-2007 at 06:44 PM.

  8. #8
    Member
    Join Date
    Oct 2005
    Location
    RI
    Posts
    165

    Mag Red
    2002 Vette

    He isn't updating the thread. My gut is telling me that since he is FI he didn't do much to upgrade the valve train and may have been floating the valves. He doesn't give any indication of power loss though. Have to admit that this is the first time I have seen this with the Scorpions which are running on a number of LSx motors so his failure really doesn't make sense. There has to be more to this story that we don't know.

  9. #9
    Member cailey37's Avatar
    Join Date
    Mar 2006
    Location
    Mississippi
    Posts
    832

    Silver
    1998 Pontiac Trans Am

    That's what I was thinking....something just isn't right......I've seen a few cars running them and nothing like that....but hey...anything is possible......I use the Harland Sharps and love em........

  10. #10
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    Quote Originally Posted by cailey37 View Post
    Read the thread....he didn't even know what ratio he had......trust me.....if the pushrods were just a little off it could of made that damage over time......could of made it 8000 miles but to have every last one of them do the same thing........sounds like an easy answer.....but hey.....wont be the first time I'm wrong...

    they would have to be alot off and causing coil bind to cause that.

    and i've been wrong many times. hopefully we'll see.

  11. #11
    No Compromise davered00ss's Avatar
    Join Date
    Jul 2005
    Location
    Plainfield CT
    Posts
    382

    RED
    2000 Camaro SS

    I was going to bring up the corvette forums threat. i would avoid them.

  12. #12
    UberTapping Friction Pimp Anthracis's Avatar
    Join Date
    Mar 2007
    Location
    Omar's Tittie Taverna & Grill, Deh Rawod
    Posts
    1,447

    18D Cock Diesel
    1999 Z28; 98 SS #2043 RIP

    It think its an install issue.
    "I am the executioner. When a crime is committed and the exalted state does not take vengeance nor move to punish, then comes time for the executioner to declare himself. I have waited long enough. The criminals are hereby sentenced to death. By fire. By earth. By water."

  13. #13
    JMAC Racing WS6ICK's Avatar
    Join Date
    Aug 2005
    Location
    Kentucky
    Posts
    535

    2000 Trans Am WS6 LS6
    2006 GTO LS2

    I have these on my 2000 Trans Am, WS6, LS6. I have the stock ratio which is 1.7 and they bolt right on. I did feel a difference. I could tell I had more pulling power and I gained .2 in a quarter mile with the Scorpion rockers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: LS1 Scorpion Roller Rockers
    By Nowhereman in forum Internal Engine
    Replies: 2
    Last Post: 08-23-2011, 04:12 AM
  2. Question: Scorpion Roller Rockers Help.
    By c0ford in forum Internal Engine
    Replies: 7
    Last Post: 09-10-2010, 09:37 AM
  3. Scorpion 1.7 roller rockers
    By C&Cbird in forum Parts For Sale / Trade
    Replies: 10
    Last Post: 04-27-2008, 06:42 PM
  4. Scorpion roller rockers?
    By porsche914ls6 in forum Internal Engine
    Replies: 1
    Last Post: 04-23-2008, 12:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •