Results 1 to 11 of 11

Need help removing/reinstalling head...

This is a discussion on Need help removing/reinstalling head... within the Internal Engine forums, part of the LSx Technical Help Section category; Hey guys... I am in the process of removing the drivers side head of my 98 trans am to replace ...

  1. #1
    Member
    Join Date
    Nov 2005
    Location
    Chelmsford, MA
    Age
    29
    Posts
    101

    Black
    1998 Trans Am WS6

    Need help removing/reinstalling head...

    Hey guys...

    I am in the process of removing the drivers side head of my 98 trans am to replace a broken pushrod... So far I have gotten all the head bolts out, but the fucking bolts holding the grounds into the back of the head wont budge, and neither will the bolts holding the P/S pump on. I have been working on the car for 4 days now and I am completely losing faith, and I am past the point of ebgine able to throw it back together and get it to a mechanic, not that I would pay some guy 1500$ to do this.

    I am just wondering if anyone has any tips for me, or if anyone is in the lowell area and would be willing to stop by and gimme a hand, cause I just dont know what to do at this point...

    Thanks
    -Scott

  2. #2
    ???? why are you pulling the head? Did you lose the broken pushrod?
    Just trying to find out and figure why the head removal? What sockets
    6 or 12 point? Remove the head with the PS not the best but still doable??
    Hawk

  3. #3
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,746

    Black
    383 Procharged & N20 Vert

    I used a 15 mm ratcheting wrench for the head bolts and a 15 mm stubby for the one PS bolt.

  4. #4
    Kill Whore LS1What's Avatar
    Join Date
    Nov 2005
    Location
    West MI
    Age
    32
    Posts
    188

    Red
    '85 GT

    Do you really have to pull heads to change out smushrods on LS1's??? Anyway, I wish I lived close I'd come gave ya hand.. Worst come to worst you can always cut the ground strap and get a new one (better too), and impact the bolt out when the heads out. Can't fit a impact up under the PS pump anywhere...? Ed you took head bolts off with a racthening wrench? How long was it? You brute monster!!

  5. #5
    Member
    Join Date
    Nov 2005
    Location
    Chelmsford, MA
    Age
    29
    Posts
    101

    Black
    1998 Trans Am WS6

    Good News!

    I got the head off! What I did was unbolt all the head bolts, then lift the head twist it a little, then unbolted the P/S pump. Then I pulled it foprward more and got to the ground bolts, which were very tight. One the the wires' connector broke off so I will have to replace those.

    And yes, I got the head bolts out with a ratchet, but My very large friend helped me ;-).

    Ok thanks guys
    -Scott

  6. #6
    Member
    Join Date
    Nov 2005
    Location
    Chelmsford, MA
    Age
    29
    Posts
    101

    Black
    1998 Trans Am WS6

    Well got everything back together last night/this morning. Took it for a drive at 3:00 AM when I finished, runs better then it did when I first got it.

    Only thing I see that is odd is the oil pressure seems a little low. It stays between 20 and 40 unkess I bring the revs very high, but mostly from 20-30 now. It used to always stick around 40 unless i drove the car for a while. Im not sure if theres something wrong now, or there was something wrong before and now its fixed, but everything else seems fine, and no more tapping I can finally sleep without hearing tap tap tap tap lol.

    Thanks
    -Scott

  7. #7
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    You could of just removed the valve covers and rockers....but yea, least you solved the prob.

  8. #8
    Member
    Join Date
    Nov 2005
    Location
    Chelmsford, MA
    Age
    29
    Posts
    101

    Black
    1998 Trans Am WS6

    no I couldnt have. See the pushrod broke and went down further into the head, not float around the top. Believe me if I could have done that and sved myself all that i would have.

    Thanks
    -Scott

  9. #9
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,746

    Black
    383 Procharged & N20 Vert

    A magnet wouldn't have gotten it out??

  10. #10
    Member
    Join Date
    Nov 2005
    Location
    Chelmsford, MA
    Age
    29
    Posts
    101

    Black
    1998 Trans Am WS6

    no, the pushrod was going perpedicular to the direction it should ahve been lol. Trust me on this one the only way was removing the head. Its all good tho cuz the car runs so much better now.

    Thanks
    -Scott

  11. #11
    N/A nitrously aspirated stangslayer98's Avatar
    Join Date
    Nov 2005
    Location
    miami,fl
    Age
    36
    Posts
    497

    black
    1998 trans am

    smushrod's im guessing that your mustang has the real pushrod's???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 02-11-2015, 03:30 AM
  2. Help reinstalling my abs/traction control
    By ghostriderb in forum Drivetrain
    Replies: 13
    Last Post: 03-12-2011, 01:26 PM
  3. Help: removing head rests
    By third_shift|studios in forum Firebird / WS6
    Replies: 14
    Last Post: 03-30-2009, 12:29 PM
  4. Replies: 2
    Last Post: 03-01-2009, 01:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •