Results 1 to 10 of 10

motor oil in coolant?

This is a discussion on motor oil in coolant? within the Internal Engine forums, part of the LSx Technical Help Section category; hello, I have never posted on here before but have been looking one here for a while. I was wondering ...

  1. #1
    Junior Member
    Join Date
    Mar 2008
    Location
    Cameron, nc
    Posts
    6

    Black
    2002 camaro z28

    motor oil in coolant?

    hello, I have never posted on here before but have been looking one here for a while. I was wondering if any body has had this problem. I was changing my coolant today and noticed what looks to be oil in the coolant tank. I drained the radiator and replaced the thermostat. The coolant draining from the engine and radiator looked ok but I found alittle oil in the coolant tank. When I refilled the radiator and ran the engine there was specks of oil floating in the top of the radiator. I have owned the car since 2005 and it had 35,000 miles on the car. It now has 46,000 and I have never had any previous problem. I also flushed out the dexcool when I purchased the car and put green coolant in. engine runs fine. I also changed the oil today and there was no coolant in it. any advise would be great.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Does your car have the power steering cooler in the upper radiator hose? I am not certain which models other than the WS6 that run that.

  3. #3
    Junior Member
    Join Date
    Mar 2008
    Location
    Cameron, nc
    Posts
    6

    Black
    2002 camaro z28

    I just looked and yes it does.

  4. #4
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Chances are you have a bad power steering cooler like Jeff said. Most people remove the factory PS cooler all together as it really isn't that effective, you can go with an aftermarket PS cooler and be much better off or replace the existing one.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Bingo. If you look around the site you will see that there have been lots of complaints about those coolers. I will be removing ours soon and replacing it with a small tube and fin Derale cooler. The fact of your recent coolant system flush should be all that was needed so no worries unless you continue to drive the car with the leaking cooler -- assuming that it is in fact the issue.

  6. #6
    Junior Member
    Join Date
    Mar 2008
    Location
    Cameron, nc
    Posts
    6

    Black
    2002 camaro z28

    thanks for the info. I will check on that. thanks

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Easiest check would be to remove the cooler from the car and immerse it in a bucket of water with a sections of hose on the P/S fluid inlets and outlets. Hit it with some air pressure -- no more than 15-18 p.s.i. -- and see if you have bubbles coming out the the ends where the upper radiator hose attaches.

  8. #8
    Mustang Eater Ls_won's Avatar
    Join Date
    Feb 2010
    Location
    Springfield, Missouri, United
    Posts
    221

    Maroon
    2000 z28 6 speed

    are you running dexcool? i know it can become discolored..
    2001 B4C Totaled 4/25/11
    2000 Z28 M6 Cammed N' Slammed (SVT KLR)

  9. #9
    Junior Member
    Join Date
    Mar 2008
    Location
    Cameron, nc
    Posts
    6

    Black
    2002 camaro z28

    no dexcool- flushed that out in 2005. I did disconnect the power steering hose going to the cooler and by-passed it. I have ran the car for a couple of weeks now and so far no oil floating in the radiator yet. I hope the powersteering cooler is bad. I will buy a upper radiator hose w/out the cooler.

  10. #10
    Mustang Eater Ls_won's Avatar
    Join Date
    Feb 2010
    Location
    Springfield, Missouri, United
    Posts
    221

    Maroon
    2000 z28 6 speed

    Sounds like the powersteering cooler. good deal man. my B4c had it too, but it never leaked!


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Need pic of coolant pump weep hole (Coolant Leak)
    By Sweet Chops in forum General Help
    Replies: 13
    Last Post: 04-20-2009, 08:14 PM
  2. Replies: 23
    Last Post: 06-19-2007, 08:28 AM
  3. Coolant light...coolant level full.
    By SR71 in forum General Help
    Replies: 4
    Last Post: 01-08-2007, 10:35 AM
  4. coolant light on, full on coolant
    By Brownboy2020 in forum Firebird / WS6
    Replies: 10
    Last Post: 08-10-2006, 01:26 PM
  5. ls6 intake coolant plugs or extra front coolant pipe?
    By mikes ss in forum External Engine
    Replies: 3
    Last Post: 12-03-2005, 05:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •