Results 1 to 10 of 10

Low oil pressure ?ls2 ported ..

This is a discussion on Low oil pressure ?ls2 ported .. within the Internal Engine forums, part of the LSx Technical Help Section category; While doing my cam swap .. i replaced the stock oil pump with the ls2 ported oil pump .. the ...

  1. #1
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    Unhappy Low oil pressure ?ls2 ported ..

    While doing my cam swap .. i replaced the stock oil pump with the ls2 ported oil pump ..

    the oil pressure seems good at the cold start "3/4" and the drops down to 1/4 after the engine warms up .. then i hear my lifters cracking .. until i rev it and get my oil pressure back!!

    what should i do ..

    please Help ..

  2. #2
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Check o-ring on pump.

  3. #3
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    thanks Mr.luos

    I'll do

    any other suggestions ?

    could it be my engine ? someone told me its normal if i have high millage !?
    am still in 95xxx !

  4. #4
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Pressure should be pretty constant with a new(er) pump.

    Were the lifters tapping before the new oil pump??

  5. #5
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    NO .. They were new ls7 lifters ..

  6. #6
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Were they pumped up before running?
    Soaked in oil before install?

  7. #7
    Member Sayed_000's Avatar
    Join Date
    Oct 2008
    Location
    Middle East - Bahrain
    Posts
    257

    Pewter
    Camaro 2000 SS M6

    i don't think so ..

    thanks Mr.Luos for the help.. am taking the car to the auto part today ..

  8. #8
    CAMARO not Maro asshead! HASTINGSRJ's Avatar
    Join Date
    Jan 2001
    Location
    MASSHOLE in Jville NC
    Age
    44
    Posts
    2,012

    Black/Gray
    00 SS Vert#0540/ 03 GMC

    should have at least dipped the lifters in oil before install. And check the o ring on the oil pump.

    http://www.gmhightechperformance.com...aro/index.html
    Black 00 SS M6, vert, #0540 414 C.I. iron block 501hp 448tq -slipping clutch
    old times 11.39@123 tuned by RPM
    11.49run


    DD 03 GMC Sierra, Durmax CCSB 2500, 17" XD's, 5" tubo back exhaust, AFE intake, EFI Live, DSP5, 3" body lift, tuned by Diesel Addiction 347hp 645tq

    rwhp.us

  9. #9
    Member 02fbody35th's Avatar
    Join Date
    Feb 2008
    Location
    scranton,pa
    Age
    31
    Posts
    279

    red
    2002 camaro 35th anv.

    yeah, these are guys are right. I would put money on it that it is the O-ring on the pump. If not installed correctly the O-ring gets pinched causing the oil to airrate once it warms up causing a drop in pressure.

  10. #10
    Just a souped up sunfire. Ryans99LS1's Avatar
    Join Date
    Jun 2007
    Location
    Parma Heights, Ohio
    Age
    27
    Posts
    891

    SOM
    99 Trans Am

    more than likely pinched o ring. i doubt its due to mileage especially since you just did a cam swap.. my 98 just turned 192k over the weekend and sits at 36-38psi when fully warm.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New .600 Springs, Ti Retainers, LCA Relo. Brackets.Ported MAF, Ported 99 TB & More
    By rcleveland@barrick.c in forum Parts For Sale / Trade
    Replies: 5
    Last Post: 11-02-2007, 10:22 PM
  2. SLP LS6 intake, Whisper Lid, Ported Throttle body, Ported MAF
    By cru ss n in forum Parts For Sale / Trade
    Replies: 15
    Last Post: 05-24-2006, 09:22 AM
  3. Replies: 3
    Last Post: 04-01-2006, 04:59 PM
  4. Looking for gauges! nitrous pressure, fuel pressure!
    By texasss in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 10-29-2005, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •