Results 1 to 3 of 3

low oil pressure

This is a discussion on low oil pressure within the Internal Engine forums, part of the LSx Technical Help Section category; I recently pulled a motor on a 2000 Z.It was knocking.I tore the engine down to discover the bearings were ...

  1. #1
    Junior Member
    Join Date
    Dec 2006
    Location
    Weslaco Texas
    Posts
    6

    Tan
    83 Olds Cutlass

    Unhappy low oil pressure

    I recently pulled a motor on a 2000 Z.It was knocking.I tore the engine down to discover the bearings were not that bad,only they fell right off the saddles.By saddles I mean the rod and main saddles.They were dark in color and a few had light scuffs.We decide we were going to reuse the crank and pistons.I honed the cylinders with a ball honer once it was returned from the machine shop where they replaced the cam bearings.The machine shop checked the crank and polished it.I replaced all the bearings with new standard bearings clevite77.New rings, oil pump, timing chain,and gaskets.New high lift and duration cam.torqued and degreed all main and rod bolts.I installed the lifters with the oil feed holes facing the oil galleys,bolted up the heads etc.I did notice the push rods were a little too short.Upon fire up,I noticed valve train noise.I told the owner he would have to replace them.He drove the car for 2 weeks and told me the oil pressure was low.All the way in the red he said.When he first starts it it is fine.Then it warms up and the oil pressure drops.He is using 10/30 royal purple.I installed the O ring correctly.For the most part I assembled the engine correctly minus the pushrods.I believe the machine shop didn't do a good job on the crank.Excessive bearing clearance?What do you think?
    Last edited by fourohsicks; 01-21-2007 at 09:58 AM. Reason: typo

  2. #2
    Senior Member Danger731's Avatar
    Join Date
    Aug 2000
    Location
    Indy
    Posts
    6,712
    clog in the pump ?

  3. #3
    Junior Member
    Join Date
    Dec 2006
    Location
    Weslaco Texas
    Posts
    6

    Tan
    83 Olds Cutlass

    we replaced

    We replaced both the pump and the oil sender.Ran the engine with the passenger side valvecover off.Oil barely squirted out the rockers?Someone told me the pushrods being short is not putting enough preload on the lifters...causing the oil pressure to be low???

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: oil pressure
    By Z28boy2000 in forum General Help
    Replies: 16
    Last Post: 07-14-2009, 08:32 AM
  2. Help: Oil pressure goes down!??
    By 98T/A.SNAKEATER_ in forum General Help
    Replies: 15
    Last Post: 11-02-2008, 07:08 AM
  3. Replies: 3
    Last Post: 04-01-2006, 04:59 PM
  4. Looking for gauges! nitrous pressure, fuel pressure!
    By texasss in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 10-29-2005, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •