Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Look at my plug. Engine is down for sure,Thoughts?

This is a discussion on Look at my plug. Engine is down for sure,Thoughts? within the Internal Engine forums, part of the LSx Technical Help Section category; Well, I wasn't let down when I finally started looking at my TA. Last time I went to the track ...

  1. #1
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Thumbs down Look at my plug. Engine is down for sure,Thoughts?

    Well, I wasn't let down when I finally started looking at my TA. Last time I went to the track last year, I had some serious engine smoking issues. The last two passe's smoked horribly. The last pass looked like i had a smoke machine behind me. Not good. I did drive it home (~40 minutes) and have started it up a few times over the winter for giggles. I finally jacked the car up today to find two bad oil leaks. Cylinder 7 and cylinder 6 have oil dripping from where the header meets the head. Not good . I pulled the plug from cylinder 7 and found this.







    I did a compression check on that cylinder and didn't get any reading at all. Was working by myself, so I'm going to attempt it tomorrow when I have a extra set of hands hopefully. What would you guy do? I obviously need the heads refurbished. I know this for a fact from that piece of shit Tim's valve spring tool. Now I am seriously feeling the shortblock is also gone. I'm in a real tough spot here, I don't wanna build another NA setup. I'm dying to go FI and feel buying any NA engine is just blowing my money away because it will not be staying NA, guaranteed. I'm a little strapped for cash right now. I kinda just felt like sharing my awesome spark plug with everyone

  2. #2
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    I'm subscribed for pics to come, it seems if it can break you always manage.

  3. #3
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by c5z28 View Post
    I'm subscribed for pics to come, it seems if it can break you always manage.
    Thanks

    I'm sure the 70+ 1/4 mile pass's last year and a few thousand spirited miles had something to do with it.

  4. #4
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Maybe a used LQ9 block and build that up for either N/A or FI?

  5. #5
    Member importhater81's Avatar
    Join Date
    Oct 2009
    Location
    chicagoland,Il
    Age
    36
    Posts
    333

    black
    02 ss camaro

    No offense,but what ever you do decide to build...the first thing I would do is get rid of the Autolite Ford plugs!!!

  6. #6
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Also, the car doesn't smoke at idle. That's the one thing that has me thinking there is a slight chance the shortblock is good. If it is, then I will fix the heads/valves and roll with it for one more race season.

  7. #7
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by cammed goat View Post
    Maybe a used LQ9 block and build that up for either N/A or FI?
    Well, LQ9 is the higher compression of the two. The shortblock in it right now is a LQ4 (9.4:1) but with a small 58CC chamber. Im hoping I can redo the heads and roll with it.

  8. #8
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Damn... that sucks big time! Odd that both banks are sucking oil. Best guess as to what died?

  9. #9
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by importhater81 View Post
    No offense,but what ever you do decide to build...the first thing I would do is get rid of the Autolite Ford plugs!!!


    They did me just fine, but when I put new plugs I will go back to NGK TR55.

  10. #10
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by pajeff02 View Post
    Damn... that sucks big time! Odd that both banks are sucking oil. Best guess as to what died?
    Best Guess:

    Nicks on the valve stem worn the valve guides down allowing oil past. This stemming from a poor valve spring compressor that pushed a few retainers into the valve stem. I did my best to remove the nicks.
    I think at high RPM oil is getting past the guides and causing the blue smoke.

    Engine and transmission are coming out regardless. I wish I had the money for a 4L80E with a brake to put back in.

    The oil dipstick shot out on my last run, that has me worrying slightly.

  11. #11
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Sounds like you are already FI... just not in a good way. Pics of whatever you find on teardown please.

  12. #12
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by pajeff02 View Post
    Sounds like you are already FI... just not in a good way. Pics of whatever you find on teardown please.
    Yup, will do. Probably wont be for awhile. I'm in a sticky situation with where my car is parked and where I will be working on it. Cant have it down for extended periods of time, and if I get it torn down with nothing to replace it, I'm screwed. Still got to figure that one out.

  13. #13
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Make sure the rings are OK as well.

  14. #14
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    That sucks man, hope you get her fixed up ssoon... and relatively cheap.

  15. #15
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Imho broken ring lands and torn up valve guides.. Motor is toast imho.. Hope it works out for ya.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  16. #16
    Senior Member Z28boy2000's Avatar
    Join Date
    Jun 2008
    Location
    Rochester, NY Rochesterracing.com
    Posts
    1,276
    2000 Camaro B4C

    i dread finding something like that on my car one day, interested to see what happend

  17. #17
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Yea, motor is not looking good. Things could be worse, at least I still have the car I just gotta make a decision on what avenue I'm gonna go down.

    A - let car sit all race season / not spend money on a build I wont be happy with in the long run

    B - fix the engine myself and get the heads re-worked. Hope to come out of it fairly cheap and run it this season NA.

  18. #18
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    There is option C- come down here and we can build her back up

  19. #19
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I have no idea -- is that a stock LS1 block, or something you upgraded to?

  20. #20
    Senior Member
    Join Date
    May 2009
    Location
    Toronto
    Posts
    1,083

    SOM
    2002 SS

    Valve guides for sure. Most likely when the head is filling up with oil it starts to seep in and suck tons in. Plugs look better than mine when I had problems.. ill get a pic or two.. I'm sure itll make you feel better. To give you an idea, picture dropping a valve at 7700 rpm

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Service engine light popped!! Thoughts ??
    By 5abivt in forum General Help
    Replies: 7
    Last Post: 04-08-2010, 03:43 PM
  2. Any thoughts on Cleaning 01 engine compartment?
    By 5abivt in forum External Engine
    Replies: 11
    Last Post: 05-06-2009, 12:22 AM
  3. Best Plug wires and plug gap
    By Intrepidman in forum General Help
    Replies: 12
    Last Post: 12-30-2008, 10:30 AM
  4. Thoughts on this cam???
    By amoulds58 in forum Internal Engine
    Replies: 36
    Last Post: 09-15-2008, 07:51 PM
  5. Spark plug wire and plug!
    By RYDER661 in forum General Help
    Replies: 2
    Last Post: 03-13-2006, 10:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •