Results 1 to 2 of 2

just got my car runs fine but it has the check engine light on

This is a discussion on just got my car runs fine but it has the check engine light on within the Internal Engine forums, part of the LSx Technical Help Section category; I just got my car back today and it runs really good only problem is that it has the check ...

  1. #1
    now greybat66
    Join Date
    Apr 2007
    Location
    bloomfield nj
    Posts
    481

    navy blue metalic
    1998 trans am conv

    just got my car runs fine but it has the check engine light on

    I just got my car back today and it runs really good only problem is that it has the check engine light on .I checked the code and its po433, does anyone know what that means? Thank you.

  2. #2
    Senior Member Street Lethal's Avatar
    Join Date
    Aug 2005
    Location
    Old Bridge "Raceway Park" N.J.
    Posts
    1,249
    2009 Corvette ZO6

    ^ P0433 Heated Catalyst Efficiency Below Threshold (Bank 2)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: SES light on but diagnostics says engine fine
    By Gale8706 in forum Internal Engine
    Replies: 17
    Last Post: 11-10-2011, 02:54 AM
  2. Check Engine light vs. Service Engine light
    By bigrig73 in forum Computer & Tuning
    Replies: 1
    Last Post: 04-20-2010, 07:11 AM
  3. engine misfires then dies, then runs fine....
    By DemonSpeed in forum General Help
    Replies: 4
    Last Post: 06-24-2009, 04:14 AM
  4. Security light stays on, but car runs fine???
    By nosvet in forum General Help
    Replies: 5
    Last Post: 06-08-2008, 07:14 PM
  5. Service engine soon light = Check engine light?
    By jinxeng in forum General Help
    Replies: 5
    Last Post: 08-11-2006, 08:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •