Results 1 to 8 of 8

Engine Problems. 1st ride

This is a discussion on Engine Problems. 1st ride within the Internal Engine forums, part of the LSx Technical Help Section category; Last fall. October 2006 I had a cam installed with all major components. Rings, pistons, valves, new LS2 timing chain ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    Pittsburgh
    Age
    38
    Posts
    17

    Yellow
    2002 Trans AM CE

    Engine Problems. 1st ride

    Last fall. October 2006 I had a cam installed with all major components. Rings, pistons, valves, new LS2 timing chain and Long tubes. The car ran great. I went to start it up today, and no go. It sat for all most six months. I gave the car some gas and it started up. I let the car warm up, but it kept stalling. It would only stay running when I gave it gas in neutral. After about five minutes I decided to take it for a ride. I put the car is 1st with the clutch on and it stalled. I drove it for a little bit, and every time I pushed the clutch in it stalled when the rpms got low. Also during the ride, the car sounding funny, allmost like a knock. Now I don't do any internal engine, so I don't have a clue on this one. Could the cam have went bad? The car ran great last year, putting down 400 horses. Now I think my truck is faster than it. Any information will be greatly appreciated.

    Sorry the cam was mild doing 224/228.

  2. #2
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    From sitting, maybe the fuel tank condinsated moister... I'd pull the fuel filter and drain some fuel into a pan to see if you have water bubbles...

  3. #3
    Pathelogical Liar BlackLT1Z28's Avatar
    Join Date
    Aug 2006
    Location
    Missouri
    Age
    30
    Posts
    1,476

    Black
    94 Camaro Z28

    Gasoline actually can 'rot' and go bad only after 2 months. So, if you have old fuel in it, that might be the problem, the gas is old and bad. If you plan on having the car sit for long periods of time, I'd put a bottle of Stabil in it to keep the fuel fresh.

  4. #4
    Member
    Join Date
    Aug 2005
    Location
    maine
    Age
    42
    Posts
    168

    black
    2000 ws6

    so now they only problem you have with gas prices so high is deciding is it worth draining the old tank and refilling it or just buying a new car with a complimentary full tank

  5. #5
    Junior Member 70RScamaro's Avatar
    Join Date
    Apr 2007
    Location
    Bellingham , WA
    Posts
    19

    89 porche Red
    1970 Camaro RallySport

    its funny people always forget that gas is the most important thing to run the engine , bad gas bad performance

  6. #6
    Junior Member
    Join Date
    Aug 2005
    Location
    Pittsburgh
    Age
    38
    Posts
    17

    Yellow
    2002 Trans AM CE

    I did put Stabil in it. So I don't think it is bad gas. Any other ideas?

  7. #7
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    Check all 8 plugs & see what they look like...
    PS.... Save the Big Hammer for last !!! LOL

  8. #8
    Junior Member 70RScamaro's Avatar
    Join Date
    Apr 2007
    Location
    Bellingham , WA
    Posts
    19

    89 porche Red
    1970 Camaro RallySport

    dude just because u put a bottle of stuff u can buy at napa doesnt mean ur gas is still good, if i were u i would drain that crappy gas , fill up some premium and see what happens, if that doesnt work then its fuel related becuase ur stalling has nothing to do with spark, could be fuel pump

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New ride, problems
    By NashCar in forum General Help
    Replies: 12
    Last Post: 05-03-2009, 05:42 PM
  2. engine problems
    By Speed Psychosis in forum General Help
    Replies: 16
    Last Post: 06-03-2008, 04:54 PM
  3. service engine soon/rough ride help please!
    By knoll5150 in forum General Help
    Replies: 5
    Last Post: 05-16-2008, 12:11 PM
  4. Very odd engine problems
    By LifesHarlequin in forum General Help
    Replies: 4
    Last Post: 12-24-2006, 08:38 AM
  5. Nothing but Engine problems
    By jwindbigler in forum Western Members
    Replies: 13
    Last Post: 10-21-2006, 10:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •