Page 1 of 4 1234 LastLast
Results 1 to 20 of 61

Engine Ping

This is a discussion on Engine Ping within the Internal Engine forums, part of the LSx Technical Help Section category; Good afternoon,I have not posted in a long time but I need advise. My engine pings at over 4500 rpms, ...

  1. #1
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Talking Engine Ping

    Good afternoon,I have not posted in a long time but I need advise. My engine pings at over 4500 rpms, at full throttle. I am using 93 octane fuel. I have switched different brands. All with the same results. It pulls real hard but when it pings I let off. Stock engine except a lid. Any suggestions? How about Seafoam? I think it might just might be carbon.

  2. #2
    NASCAR Go Fast, Turn Left ntimid8r's Avatar
    Join Date
    Aug 2001
    Location
    San Diego, CA
    Posts
    8,048

    383 w/Meth & ProCharger
    2001 Camaro Z28

    Do you get a SES light? Have you ever changed the spark plugs? I'm guessing the plugs aren't firing as sharply as needed. Normally pinging is a timing issue, but you're not modded and I'm sure this issue has slowly building up...not an overnight thing or something you've had since new.

  3. #3
    Factory Freak Mikat1's Avatar
    Join Date
    Sep 2009
    Location
    Upper California
    Posts
    219

    Artic
    2002 Z28

    +1

  4. #4
    NASCAR Go Fast, Turn Left ntimid8r's Avatar
    Join Date
    Aug 2001
    Location
    San Diego, CA
    Posts
    8,048

    383 w/Meth & ProCharger
    2001 Camaro Z28

    Quote Originally Posted by Mikat1 View Post
    +1
    Stupid???

  5. #5
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    No SES light has factory Denso plugs.

  6. #6
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    change plugs stay away from shell gas

  7. #7
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    check the batt and the alt

  8. #8
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    fuel filter

  9. #9
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Ok thanks for the input, the fuel filter is a month old.

  10. #10
    Factory Freak Mikat1's Avatar
    Join Date
    Sep 2009
    Location
    Upper California
    Posts
    219

    Artic
    2002 Z28

    Quote Originally Posted by ntimid8r View Post
    Stupid???
    only icon with a sign and arrow.. don't get upset
    Last edited by Mikat1; 01-11-2010 at 01:53 PM.

  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Maybe cat heat shield or manifold heat shield?

  12. #12
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    the first thing I would do is log it to verify the knock and see just how much it's pulling. I would look at your fueling next and see if you were lean and go from there. It could just be carbon build up or you could be going lean or have an injector issue. It could be a bunch of things really. The first step is to log it though if you have access to a scanner.

  13. #13
    Member 02fbody35th's Avatar
    Join Date
    Feb 2008
    Location
    scranton,pa
    Age
    31
    Posts
    279

    red
    2002 camaro 35th anv.

    Quote Originally Posted by Retired Cop View Post
    Good afternoon,I have not posted in a long time but I need advise. My engine pings at over 4500 rpms, at full throttle. I am using 93 octane fuel. I have switched different brands. All with the same results. It pulls real hard but when it pings I let off. Stock engine except a lid. Any suggestions? How about Seafoam? I think it might just might be carbon.
    I feel your pain man, I have a 02 Z28 m6 with the same exact problem. I have been chasing forever. and tried everything(spark plugs, wires, fuel filter, air filter, maf cleaning, seafoam) I even upgraded the PCV system to an LS6 system with a catch can to prevent oil vapor. also replaced the knock sensors because of tsb gm put out, and O2 sensors. NOTHING WORKED. So pleaseeeeee !!!!!! if you figure this out or any body knows the answer please tell us.

  14. #14
    What Would Earl Do? Vexzer's Avatar
    Join Date
    Apr 2007
    Location
    Kirby, TX
    Posts
    230

    Fire
    2002 SS

    Quote Originally Posted by Retired Cop View Post
    Good afternoon,I have not posted in a long time but I need advise. My engine pings at over 4500 rpms, at full throttle. I am using 93 octane fuel. I have switched different brands. All with the same results. It pulls real hard but when it pings I let off. Stock engine except a lid. Any suggestions? How about Seafoam? I think it might just might be carbon.
    Sounds like it needs an "Italian Tune-up".

  15. #15
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by 02fbody35th View Post
    I feel your pain man, I have a 02 Z28 m6 with the same exact problem. I have been chasing forever. and tried everything(spark plugs, wires, fuel filter, air filter, maf cleaning, seafoam) I even upgraded the PCV system to an LS6 system with a catch can to prevent oil vapor. also replaced the knock sensors because of tsb gm put out, and O2 sensors. NOTHING WORKED. So pleaseeeeee !!!!!! if you figure this out or any body knows the answer please tell us.

    Just as Orion said,,,it's best to log it and see whats going on. Paying more attention to knock and how much timing it's pulling, injector duty cycle etc....
    It will narrow it down and save you alot of money from throwing parts at it
    Since this is a high rpm type of ping,,,I'd also hook up a fuel pressure gauge and go for a drive. Make sure the pressure isn't dropping off. Could be a weak fuel pump that just can't keep up.

  16. #16
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Ok thanks for the replies. Maybe I will use this excuse to get a C6 !

  17. #17
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Firebird Jones did u replace the fuel pump?

  18. #18
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Sorry I meant 02Fbody35th

  19. #19
    Member 02fbody35th's Avatar
    Join Date
    Feb 2008
    Location
    scranton,pa
    Age
    31
    Posts
    279

    red
    2002 camaro 35th anv.

    no man, i didnt but my next objective was to pressure test the fuel line. i just have to wait because it is in storage for the winter right now

  20. #20
    Member
    Join Date
    Oct 2008
    Location
    Miami, Fla
    Posts
    200

    Spiral Gray
    2004 Auto Corvette

    Man its 40 degrees in South Fla and we are freezing !! LOL !! You think it wants some hot chocolate !!

Page 1 of 4 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Engine ping
    By 02fbody35th in forum General Help
    Replies: 2
    Last Post: 03-21-2010, 07:01 AM
  2. Question: engine ping
    By 02fbody35th in forum Internal Engine
    Replies: 4
    Last Post: 02-20-2010, 09:33 PM
  3. Help: Engine Ping When Accelerating
    By CJoel in forum General Help
    Replies: 21
    Last Post: 09-08-2009, 01:26 PM
  4. Engine Knock Ping Might be trouble
    By dr_ws6_00 in forum Internal Engine
    Replies: 5
    Last Post: 09-15-2007, 05:09 PM
  5. bad engine ping after mod install
    By mvvette97 in forum External Engine
    Replies: 3
    Last Post: 08-31-2006, 09:16 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •