Results 1 to 4 of 4

down 80 hp, problem in bank one. what to check.

This is a discussion on down 80 hp, problem in bank one. what to check. within the Internal Engine forums, part of the LSx Technical Help Section category; My car is donw 80 hp. The o2 readings from bankone say that I have low voltage. I had the ...

  1. #1
    Member RealLiveMD's Avatar
    Join Date
    Feb 2006
    Location
    Memphis
    Posts
    262

    Black
    2002 WS6

    down 80 hp, problem in bank one. what to check.

    My car is donw 80 hp. The o2 readings from bankone say that I have low voltage. I had the cam and springs redone by a shop. The thold cam was beat up. They replaced the cam,... not the lifters and the car made 427/415. When I received the car back though, its a slug. now making 350. My theory is that the bad old lifters have ground into the new cam. Oddly though, I don't hear lifter noise. I've replaced, plugs, coil pack and check ground strap wire on head. Other than pulling the head and starting over, Is thare anything else, I should check? They replaced the springs too, If there is anything that you guys could think of that could come loose on one side of the motor let me know. old cam picture attached.

  2. #2
    Member My00Z28's Avatar
    Join Date
    Sep 2010
    Location
    Holland, MI/Lima, OH
    Age
    26
    Posts
    822

    Red
    2000 Camaro Z28 A4

    Quote Originally Posted by RealLiveMD View Post
    My car is donw 80 hp. The o2 readings from bankone say that I have low voltage. I had the cam and springs redone by a shop. The thold cam was beat up. They replaced the cam,... not the lifters and the car made 427/415. When I received the car back though, its a slug. now making 350. My theory is that the bad old lifters have ground into the new cam. Oddly though, I don't hear lifter noise. I've replaced, plugs, coil pack and check ground strap wire on head. Other than pulling the head and starting over, Is thare anything else, I should check? They replaced the springs too, If there is anything that you guys could think of that could come loose on one side of the motor let me know. old cam picture attached.
    if the old cam's lobes were beat then the lifters are going to look just like the old cam! lifters should of been replaced or you can say bye bye to that cam because it will wear out fast... if the o2 is reading low voltage then it is running lean(to much air and not enough fuel)! check for vacuum leaks

  3. #3
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    What springs what cam? A broken dual coil spring could do this. Pull the valve covers and check em out.

  4. #4
    Member RealLiveMD's Avatar
    Join Date
    Feb 2006
    Location
    Memphis
    Posts
    262

    Black
    2002 WS6

    I don't know what the f is wrong with the car I pulled the valve covers and springs look and sound fine. No lifter noise as I would expect. The tuner says he redynoed the car after pulling five degrees and the power was fine so that's not it I'm buying new o2s. This am.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ok so check this problem out..
    By Ws6islife in forum General Help
    Replies: 11
    Last Post: 02-26-2010, 08:52 AM
  2. Problem with one cylinder bank going lean.
    By Sam-SS in forum Computer & Tuning
    Replies: 4
    Last Post: 11-01-2007, 07:13 AM
  3. Replies: 3
    Last Post: 08-19-2007, 04:12 PM
  4. Cheaper Than Dirt Customers: Check your bank statments
    By KC&97TA in forum Almost Anything Goes
    Replies: 6
    Last Post: 08-06-2007, 01:53 PM
  5. bank 1 bank 2 sensor locations?
    By Hector in forum General Help
    Replies: 6
    Last Post: 03-13-2007, 06:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •