Results 1 to 3 of 3

Diagnosing Low Oil Pressure. Help!

This is a discussion on Diagnosing Low Oil Pressure. Help! within the Internal Engine forums, part of the LSx Technical Help Section category; I dont know too much about the internal parts of an engine but man I have done a crap load ...

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Location
    East Wareham, MA
    Posts
    31

    Black
    2000 Trans Am

    Diagnosing Low Oil Pressure. Help!

    I dont know too much about the internal parts of an engine but man I have done a crap load of work on my car and its always something. Im lucky to get a week of driving out of it since I bought this lemon. My latest problem is Low Oil Pressure and the problem started after losing Oil Pressure completely and having to install a new Front Main Seal and Harmonic Balancer. THat is all installed correctly but something changed in the cars performance after resolving part of the original problem. My car will start out at about 35 PSI when started and stay around 25 PSI when warmed up. It usually would sit at 40 and get up to 60 or 70 when I jumped on it. Now when I jump on it the pressure stays at about 30 or so and actually dips a bit while first jumping on it. Of course this is the opposite effect I was used too. Does anyone know what the problem may be? O-Ring im guessing but I dont know much in this area. Nor do I know how much this one is gonna cost me. Ive already spent alot of money on fixing this car and it just doesnt ever stop.

    New Driveshaft
    New Clutch, Pressure Plate, Flywheel
    Rebuilt Transmission (Ordered D&D Performance rebuilt kits)
    New Water Pump
    New Harmonic Balancer and Front Main Seal
    New Slave and Master Cylinder
    Bought the Ram Air Screens due to large debri getting into the Air Filter

    Previous owner was a piece of work!

    These were all problems and not done by my choosing.

    Existing Problems

    Security Light (Pisses me off)
    Drivers Side Power Lock (Unlock Specifically)
    Passenger Seat (Power Seat Problem) I know, big deal

    Damn rattling right in back of my head that I cant pin the sound on. It rattles like a bolt being shaked in a soda can. Ive taken my panels off and reached in to feel everywhere in search of something loose. Even went under the car. I guess I need a second person to figure that one out.


    Anyway enough of my venting. I just want to figure out the initial problem I mentioned above. Looks like im gonna get raped by a dealer unless this one is easy to fix....

  2. #2
    Member Stricken1's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Posts
    248

    Black
    2001 Trans Am WS6

    It maybe as simple as your oil filter. The Purelator Pure on will restrict flow if you jump on it. It did it to mine so I changed to the M1 filter. 40 PSI is normal...50-70 while driving with your foot down is okay but 25PSI is to low for any reason. My LT1 use to be 30 at idle 40-45 while driving. But it had 115K on it.

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Location
    East Wareham, MA
    Posts
    31

    Black
    2000 Trans Am

    I have the same Oil Filter on the car as before the problem I have above and it worked fine. Im guessing that its a pressure loss due to a blown seal from the engine somewhere. I just dont know much about it. The problem happened after losing all pressure in the engine due to the harmonic balancer coming off from the previous owners lack of installation knowledge. I did the main seal on the engine and a new harmonic balancer and bolt of course and bought the correct GM Tools. The harmonic balancer is correctly installed but something else is wrong with the car from when I had the loss of pressure. Being an idiot I drove the car a few miles to get it home. When you drive a car with no pressure I am aware that you can kill the Engine if its for too long. However I am wondering what can happen to the motor that would cause my current problem. The engine runs strong so I know its not f'd up. However I am thinking that someone in here who knows alot about engine work would know what seal is likely to go when the above described situation happens.... Any insight would be great.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help diagnosing my LT1 (San Diego)
    By Omega Supmeme in forum Western Members
    Replies: 5
    Last Post: 05-30-2011, 05:31 PM
  2. Need Help Diagnosing a code.. Please....
    By rcorte3001 in forum General Help
    Replies: 5
    Last Post: 03-17-2011, 07:47 PM
  3. NEED HELP ON diagnosing MY 2001 Ws6
    By dabatman01 in forum Firebird / WS6
    Replies: 16
    Last Post: 08-24-2010, 06:26 AM
  4. need help diagnosing vibration
    By Red Camaro SS in forum General Help
    Replies: 10
    Last Post: 06-11-2007, 12:40 PM
  5. help diagnosing ses?
    By gary26154 in forum General Help
    Replies: 1
    Last Post: 04-04-2006, 03:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •