Results 1 to 6 of 6

Confused

This is a discussion on Confused within the Internal Engine forums, part of the LSx Technical Help Section category; So today I installed my factory tune from my predator. When I took it for a drive I noticed rattling ...

  1. #1
    Rice killa 01NavyBlueSLPSS's Avatar
    Join Date
    Dec 2010
    Location
    Washington
    Posts
    100

    Navy Blue Metallic
    01 Camaro SS M6

    Confused

    So today I installed my factory tune from my predator. When I took it for a drive I noticed rattling noise when I accelerated hard. Sounded like pre detonation. So I re installed the predator tune and now it's gone. So wtf. Why would I be getting pd from my stock tune? Btw the car was dyno tuned at some point before I bought the car. Idk if that has anything to do with it or not. I'm really hoping no damage was done to the engine for the 15 mins that I drove it....

  2. #2
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    Handheld tuners have been known to cause issues. They usually tend to do more harm than good. I doubt any serious harm was done, but I'd avoid using it again.

  3. #3
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    As for why it caused the problem, I'd guess that the handheld doesn't take into account any changes that were made to the tune when it was dynoed. It simply adjusts things based on what they would have been set to by GM. In effect, it is over-adjusting the tune, because it doesn't take into account the adjustments already made.

  4. #4
    Rice killa 01NavyBlueSLPSS's Avatar
    Join Date
    Dec 2010
    Location
    Washington
    Posts
    100

    Navy Blue Metallic
    01 Camaro SS M6

    Looks like I can never run my stock tune again. Which sucks because my speedo is off with the predator tune. But the upside is my engine runs cooler

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    What mods have been done? Was it the stock tune or dyno tune saved on the Predator? Most handhelds include speedometer calibration -- check your instructions as I am not familiar with the Predator. The cooler running may be due to recalibrated fan settings if you have a 160 or 180 degree thermostat.

  6. #6
    Rice killa 01NavyBlueSLPSS's Avatar
    Join Date
    Dec 2010
    Location
    Washington
    Posts
    100

    Navy Blue Metallic
    01 Camaro SS M6

    No idea where the dyno tune was saved. The only mode dones to the engine is underdrive pulley. Also, I had the programmer plugged in for live data feed last night, and when I went wot my spark advance jumped clear to 48 degrees on the predator tune. Isnt that waay high?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. confused..
    By jakez28 in forum Request and Feedback
    Replies: 3
    Last Post: 04-03-2010, 12:56 AM
  2. confused
    By kamahlwolf in forum Firebird / WS6
    Replies: 13
    Last Post: 03-27-2010, 06:59 AM
  3. confused??
    By jmatt07 in forum Internal Engine
    Replies: 14
    Last Post: 01-12-2009, 12:05 AM
  4. Im so confused
    By JoshieDoom in forum Almost Anything Goes
    Replies: 6
    Last Post: 02-12-2008, 01:39 AM
  5. i am very confused
    By purplebat66 in forum General Help
    Replies: 6
    Last Post: 08-08-2007, 02:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •