Results 1 to 8 of 8

cold start ticking sound

This is a discussion on cold start ticking sound within the Internal Engine forums, part of the LSx Technical Help Section category; Anyone have this problem? Sounds like lifters but dealer says it normal for a LS1. I can't buy that story. ...

  1. #1
    Junior Member
    Join Date
    Nov 2007
    Location
    tennessee
    Posts
    12

    red
    2000

    cold start ticking sound

    Anyone have this problem? Sounds like lifters but dealer says it normal for a LS1. I can't buy that story. It goes away in 30 seconds and runs perect. It's driving me crazy. Any ideas?

  2. #2
    Junior Member
    Join Date
    Nov 2007
    Location
    McAllen, Tx
    Posts
    3

    White w/ Blue Stripes
    Ram Air 30th Anniversary

    Our cars do the same thing. My wife & I have two 30th anniversary ram airs. Car#s 1103 & 0794.

  3. #3
    Ebaaaaaaaaa Speedy_Gonzales's Avatar
    Join Date
    Sep 2006
    Location
    Georgia
    Posts
    11,019

    Black
    2014 Camaro 1LS

    the ole piston slap...wont harm a thing, when I first heard it I was really concerned till I did some research

  4. #4
    Junior Member HotRodz28's Avatar
    Join Date
    Feb 2007
    Location
    Georgia
    Age
    35
    Posts
    51

    Black
    2002 Camaro Z-28

    same here

    I have the same problem and thay told me the samething. Even some of my friends that have them said that to. thay told me no worries.

  5. #5
    11.9 at 118 02Ls1Formula's Avatar
    Join Date
    Dec 2006
    Location
    gainesville, ga
    Age
    31
    Posts
    491

    SOM
    2002 firebird formula

    i got it after i installed my LTs....starts to do it when it firsts starts up till it gets warmed up

  6. #6
    Junior Member
    Join Date
    Nov 2007
    Location
    tennessee
    Posts
    12

    red
    2000

    Thanks guys for the reply

    I feel a little better knowing other folks have the same problem and it's normal. Thanks again

  7. #7
    Junior Member HotRodz28's Avatar
    Join Date
    Feb 2007
    Location
    Georgia
    Age
    35
    Posts
    51

    Black
    2002 Camaro Z-28

    No problem, I was worried at first too.

  8. #8
    Impounded
    Join Date
    Mar 2007
    Location
    Milwaukee
    Age
    30
    Posts
    2,159

    Red
    2000 Trans Am

    Same here still drive great and runs fast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ticking sound in a 98 Z71
    By red99ws6 in forum GM Trucks
    Replies: 1
    Last Post: 09-20-2008, 11:33 AM
  2. Help: Cold Start Ticking Noise
    By Justin93 in forum General Help
    Replies: 5
    Last Post: 07-13-2008, 01:03 PM
  3. Ticking sound
    By GottaHaveLS1 in forum General Help
    Replies: 12
    Last Post: 09-07-2007, 02:48 PM
  4. ticking sound, help!
    By sund0wn in forum General Help
    Replies: 5
    Last Post: 08-17-2007, 05:25 PM
  5. ticking sound from engine??
    By 1stgto in forum GTO
    Replies: 14
    Last Post: 06-14-2007, 10:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •