Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25

CAM worn lobe??

This is a discussion on CAM worn lobe?? within the Internal Engine forums, part of the LSx Technical Help Section category; Originally Posted by nativetalon I'm not sure what you mean, and if so, how do i fix it? These engines ...

  1. #21
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by nativetalon View Post
    I'm not sure what you mean, and if so, how do i fix it?
    These engines don't have adjustable valvetrains from the factory,,,meaning the rocker arms are torqued to spec and that's it. The lifter preload and valvetrain geometry is set by the pushrod length.

    You mentioned you installed new rockers, but didn't mention if you converted to adjustable or not. There are many kits out there that allow adjustability so you can set preload to a desired amount.

    I don't remember if you mentioned replacing push rods either. The standard length seems to be in the 7.4" area, but I've been hearing that alot of shops are going just a tad longer now on the "NON" adjustable setups to quiet the lifter noise down a bit.

    Not to mention also,,,,larger camshafts generally are ground with a smaller base circle (that's how the lift is obtained) which in most cases requires a longer pushrod anyway to get valvetrain geometry back in check,,,and also set proper preload on the lifters if your valvetrain is "NON" adjustable.
    Last edited by Firebirdjones; 02-24-2011 at 07:39 PM.

  2. #22
    Junior Member nativetalon's Avatar
    Join Date
    Dec 2007
    Location
    pembroke, nc
    Age
    34
    Posts
    59

    silver & black
    2000 TA 1979 TA

    how would i know the difference? and i bought comp cams ultra gold rockers and also 7.4 pushrods. how will i know if i need longer pushrods, and how do i measure to assure proper lenght?

  3. #23
    Junior Member nativetalon's Avatar
    Join Date
    Dec 2007
    Location
    pembroke, nc
    Age
    34
    Posts
    59

    silver & black
    2000 TA 1979 TA

    and also, cam lift is 601/612

  4. #24
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by nativetalon View Post
    how would i know the difference? and i bought comp cams ultra gold rockers and also 7.4 pushrods. how will i know if i need longer pushrods, and how do i measure to assure proper lenght?
    Hmmm, I'm looking at the comp cam website. There is no mention of whether or not the the ultra gold rockers for the LS engines are adjustable or not. They only say they are stud mounted. So I can only guess.

    I run stud mounted Crane roller rockers and they are fully adjustable. There are others out there that stud mount,,,but are not adjustable and basically mount onto a stud that is bevelled. Much like a conventional pontiac engine similar to what your 79 firebird in your picture would have.

    I'm taking it that you didn't install the parts? You would have either simply torqued the rockers down to spec and let it be, as preload is set by pushrod length. Or you would have had to adjust lifter preload with each individual rocker. Setting lash just as you would on an older GEN 1 SBC.

  5. #25
    Junior Member nativetalon's Avatar
    Join Date
    Dec 2007
    Location
    pembroke, nc
    Age
    34
    Posts
    59

    silver & black
    2000 TA 1979 TA

    no i paid Larry Turner's Performance $850 to do the work with $4000 in parts and the 1st time i got it home it sounded ok when i left the garage about 30 miles away. but it was ticking by the time i got home. and finally started to sound like a rocker was coming aloose so he then come bak amd got it. then again when i drove it home it started the same ticking and it has been parked since last march. o haven't had the cash to find out what it is until now. so this time I'm going to try to do the work myself. what do you suggest? different rockers?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Worn Out Upholsetry
    By navyLS1 in forum Firebird / WS6
    Replies: 4
    Last Post: 01-31-2010, 07:40 PM
  2. What are the Symptoms of a bad cam lobe
    By Justin93 in forum Internal Engine
    Replies: 6
    Last Post: 04-16-2009, 01:08 AM
  3. Camshaft Lobe Separation Angle Performance Test -
    By Ed Blown Vert in forum Camaro / SS
    Replies: 5
    Last Post: 04-01-2009, 07:56 AM
  4. Lobe Sep.
    By QUIK SILVA in forum Internal Engine
    Replies: 21
    Last Post: 01-19-2007, 05:15 PM
  5. lobe separation question
    By zman98 in forum Internal Engine
    Replies: 4
    Last Post: 06-30-2006, 08:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •