Results 1 to 9 of 9

burning oil? i dunno (help)

This is a discussion on burning oil? i dunno (help) within the Internal Engine forums, part of the LSx Technical Help Section category; soo heres the thing. i have an 01 z28 w 54k on it. its a very strong running car, very ...

  1. #1
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120

    burning oil? i dunno (help)

    soo heres the thing. i have an 01 z28 w 54k on it.
    its a very strong running car, very clean, not beaten on. the owner before me used mobil 1 and i use royal purple. i changed the oil for the first time being the owner on 6/7/08..i checked the oil on 7/9/08 and the level was halfway between operating range and add (in the middle of the rigid area)...
    sooo i added a half a quart and was fine and just checked it today and im at the exact same halfway mark...what can this be?? am i really burning oil? what can be the problem here and how can i fix it?? also is it bad to be driving in that rigid area? is that the operating range?
    01 m6 z28 - lid / lt headers / 3' ory w no cats / flowmaster catback w 3' dmh e-cutout / nelson pcm tune

  2. #2
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120
    anyone?

  3. #3
    Simpsons Did it!! 98formy's Avatar
    Join Date
    Mar 2007
    Location
    Minnesota
    Age
    36
    Posts
    596

    83 Z28 new project
    98 Formula WS7-sold:(

    First off, get rid of the royal purple. That crap is garbage. It could be using oil through the pcv valve, mine has that problem, but not as bad as yours. Oil could be getting past the rings or though the valve seals also. Have you looked underneath it for obvious leaks?

  4. #4
    cutting and welding mark21742's Avatar
    Join Date
    Mar 2008
    Location
    mercersburg pa
    Posts
    6,443

    hugger orange
    2004

    I agree with 98formy, so to answer you other question, the ridge lined area is the safe operating level, keep it above the bottom of the ridges and below the top....over filling the oil can do damage too. you might also want to look into getting a catch can too

  5. #5
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120
    Quote Originally Posted by 98formy View Post
    First off, get rid of the royal purple. That crap is garbage. It could be using oil through the pcv valve, mine has that problem, but not as bad as yours. Oil could be getting past the rings or though the valve seals also. Have you looked underneath it for obvious leaks?
    Quote Originally Posted by mark21742 View Post
    I agree with 98formy, so to answer you other question, the ridge lined area is the safe operating level, keep it above the bottom of the ridges and below the top....over filling the oil can do damage too. you might also want to look into getting a catch can too
    hmm it doesnt leak anything cause i keep it in my garage. and theres never anything on the ground. not even a drop...shit im stumped

  6. #6
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120
    where can i find the pcv valve? isnt in the back of the engine somewhere?

  7. #7
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    Quote Originally Posted by Raoul-Duke View Post
    where can i find the pcv valve? isnt in the back of the engine somewhere?
    Look on the passenger side of the intake manifold, between the valve covers and the fuel rail. There should be a rubber line going from the back of the motor to a port on the side of the throttle body. The PCV valve should be located in that hose.

  8. #8
    Your dealership guy konigandy6's Avatar
    Join Date
    Aug 2007
    Location
    Romeo, MI
    Posts
    6,557

    Velocity Yellow
    2008 Corvette Z06

    Check your coolant in the radiator and make sure the oil and coolant havent been mixing. This could mean a cylinder head issue.

  9. #9
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    How much oil did you add when you did the change? Did you fill the filter also? are you sure your not leaking or mixing with coolant? Also how long after you drove it did you check it? Did you give it enough time to drain back to the pan?
    I honestly dont think you would use a half of quart in a day. Unless your pouring oil out somewhere.
    J
    2001 SS, Its not the car its the Driver that matters....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dunno what to do
    By 95camaroZNC in forum Almost Anything Goes
    Replies: 25
    Last Post: 01-01-2011, 02:31 PM
  2. Soo i dunno whats going on
    By 95camaroZNC in forum General Help
    Replies: 28
    Last Post: 03-11-2009, 02:47 PM
  3. Dunno what this is...
    By Tobynine9 in forum Almost Anything Goes
    Replies: 29
    Last Post: 12-13-2008, 10:50 PM
  4. I dunno what to make of this.
    By 02cetransam in forum Almost Anything Goes
    Replies: 4
    Last Post: 09-16-2007, 09:33 AM
  5. I dunno what to do
    By fordkiller in forum External Engine
    Replies: 3
    Last Post: 03-20-2006, 01:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •