Results 1 to 4 of 4

bad rad cap??

This is a discussion on bad rad cap?? within the Internal Engine forums, part of the LSx Technical Help Section category; last summer i had my car at a garage b/c the power steering pump went and it was spitting antifreeze ...

  1. #1
    Junior Member
    Join Date
    Jul 2006
    Location
    llewellyn pa
    Posts
    29

    pewter
    2000 ss

    bad rad cap??

    last summer i had my car at a garage b/c the power steering pump went and it was spitting antifreeze out the ressy. So they told me they fixed it and shit and it was covered under warrenty. They said they took the heads off to see if it was head gaskets,supposidly they sent the heads out and shit to see if they were scared at all...they came back clean..so they repalce the gaskets and put the heads back on. but now it is doin the same shit it was...it dont over heat at all.nothing like that..oh and instead of just puttin antifreeze back in it they put some kind of stop leak in it too..so it makes me wonder if they really did all that work?! But anyway i was wondering if anyone had any ideas?it didnt do it all winter..until now. Its like 85-90 degrees

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    I am guessing you are talking about it pushing coolant out the power steering resoviour. IF so its the power steering cooler in the lower rad hose, that two piece aluminum pipe looking thing.

    Get that replaced and flush booth systems out.

  3. #3
    Junior Member
    Join Date
    Jul 2006
    Location
    llewellyn pa
    Posts
    29

    pewter
    2000 ss

    that can happen? but no thats not it...it is pushing out the antifreeze ressy...like there is way to much pressure or sumthing..you know what i mean...it just blows out the antifreeze cap like crazy...only when it is hot out tho..? it has me so confused

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Yea it can happen, rarely but it has come up a couple of times. I would replace the rad cap first and see what that does.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •