Results 1 to 7 of 7

Backfire?

This is a discussion on Backfire? within the Internal Engine forums, part of the LSx Technical Help Section category; The last few nights after work I start my drive home and when I hold third gear at about 2K ...

  1. #1
    Junior Member
    Join Date
    Sep 2005
    Location
    Northern California
    Posts
    42

    Arctic White
    98 Z-28

    Backfire?

    The last few nights after work I start my drive home and when I hold third gear at about 2K rpm and let off the gas there seems to be a slight backfire. Car runs fine and doesn't really do it when it gets warm. Is this normal? No other symptoms; just sounds like its shooting ducks.

  2. #2
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    6sp auto? If you just let off the gas while in gear you can expect that to happen.

  3. #3
    Junior Member
    Join Date
    Sep 2005
    Location
    Northern California
    Posts
    42

    Arctic White
    98 Z-28

    6sp...guess that's normal then.

  4. #4
    Member Maro SS's Avatar
    Join Date
    Mar 2009
    Location
    Oldbridge
    Age
    28
    Posts
    303

    Black
    2001 Camaro SS

    Same happens to me. I was told it was normal too
    2001 Camaro SS M6 SLP LMII, Lid
    1987 iroc-z RIP 5.7 TPI Full exhaust, lingenfelter intake runners (gone but not forgotten)
    1991 bmw 325i DD

  5. #5
    Senior Member bills98ta's Avatar
    Join Date
    Feb 2007
    Location
    St Thomas, PA
    Posts
    5,047

    White
    1998 Trans Am

    An exhaust leak can cause it also.

  6. #6
    Member Blue28's Avatar
    Join Date
    Nov 2007
    Location
    Ca.
    Posts
    769

    Navy Blue
    1999 Camaro Z28

    It could be the Check Valves for the A.I.R. system that mount to each exhaust manifold. That's if you haven't removed it yet.

  7. #7
    In need of another LS1 00blacktransam112's Avatar
    Join Date
    Aug 2008
    Location
    Sutton MA
    Age
    27
    Posts
    258

    Black
    2000 Pontiac TA

    i had same problem. probably an exhaust leak. but when i deleted the AIR system it took care of itself. no more backfiring
    00 Trans Am:LS1-M6-SLP loudmouth 1-Lid-Bellows-CAI kit-85mm MAF-B&M ripper shifter-Torque Arm-LCA-Panhard Bar-STB-EGR AIR delete

    This winter: Torquer V.2-LS6 intake-LT's-Monster clutch-Custom y-pipe-and a really good tune

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Backfire
    By 98warbird in forum General Help
    Replies: 1
    Last Post: 12-22-2008, 04:41 PM
  2. Question: !!!!backfire!!!
    By pmolina0436 in forum GTO
    Replies: 20
    Last Post: 09-27-2008, 09:15 PM
  3. Some causes of backfire
    By chuckie669 in forum General Help
    Replies: 9
    Last Post: 05-20-2008, 03:56 PM
  4. Need Help with backfire!
    By borgejr in forum General Help
    Replies: 0
    Last Post: 08-10-2007, 09:41 PM
  5. Backfire
    By feet739 in forum Internal Engine
    Replies: 10
    Last Post: 09-21-2006, 06:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •