Results 1 to 5 of 5

Antifreeze leak?

This is a discussion on Antifreeze leak? within the Internal Engine forums, part of the LSx Technical Help Section category; So in my 99, I just replaced the overflow tank because it would leak antifreeze. That fixed it and the ...

  1. #1
    Junior Member
    Join Date
    Jun 2014
    Location
    Connecticut
    Posts
    71

    Black
    99 Trans Am WS6

    Antifreeze leak?

    So in my 99, I just replaced the overflow tank because it would leak antifreeze. That fixed it and the tank level is fine. Now after running hot and it cools off the antifreeze seems to disappear from the radiator without any sogns of leaks. The oil also looks perfect. Any ideas of what could be going on? Thank you

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Check your passenger side floorboard. Is it damp?

  3. #3
    Junior Member
    Join Date
    Jun 2014
    Location
    Connecticut
    Posts
    71

    Black
    99 Trans Am WS6

    No it's not. I just replaced the radiator cap. I notice it was fitting loose so maybe there was an air leak and it doesn't have enough pressure to fill the radiator up. I'll test drive it tomorrow

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    My guess is that the space you are seeing at the top of the radiator is fairly normal. It'll push fluid into the overflow when hot and suck it back in when it cools. As long as the level stays consistent I wouldn't worry about it. I would recommend though that you check both your transmission (if A4) and your power steering as they are also cooled by the radiator. Looks for any yellow/white sludge on the dipsticks -- that is a sign of water contamination.

  5. #5
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    Any sweet, white smoke from the exhaust ?
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. antifreeze
    By V8MUSCLE in forum Almost Anything Goes
    Replies: 23
    Last Post: 02-17-2010, 06:32 AM
  2. Leaking antifreeze
    By BlackbirdRamAir in forum External Engine
    Replies: 2
    Last Post: 02-10-2010, 04:08 AM
  3. Antifreeze...
    By guitarjay76 in forum General Help
    Replies: 3
    Last Post: 06-07-2009, 08:27 AM
  4. ttop leak, hatch leak, and window motor problems
    By ATCharming in forum General Help
    Replies: 41
    Last Post: 07-23-2007, 03:30 AM
  5. Antifreeze smell
    By repeter in forum GTO
    Replies: 0
    Last Post: 05-21-2007, 07:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •