Results 1 to 5 of 5

No Oil Pressure!

This is a discussion on No Oil Pressure! within the V6 forums, part of the Vehicle Specific category; So i changed my oil today. After i finished up, started it up and have no oil pressure. Backed it ...

  1. #1
    Oh No! Its the Cops 95Fyrebyrd's Avatar
    Join Date
    Jan 2008
    Location
    Columbus, Oh
    Posts
    164

    turquoise
    1995 Firebird

    No Oil Pressure!

    So i changed my oil today. After i finished up, started it up and have no oil pressure. Backed it out of the driveway and nothing took it around the block it rised just shy above the little red line. I cant figure it out. Ive changed my oil many times and never had this problem. Any help please. Ive got a 95 3.4l V6 firebird. i thought to myself maybe i smacked a sensor or something while putting the oil filter on, i looked around nothing looked out of place. so i cant figure it out what it is...need some help, gotta have my car for work on monday.

  2. #2
    Senior Member TransAm11973's Avatar
    Join Date
    Nov 2007
    Location
    in my Trans Am
    Posts
    2,630

    Black
    2000 Trans Am WS6

    i am going to assume you double checked and still have the same amount of oil in the car as when you filled it up....so that will rule out a leak....next did you replace the oil filter with a new one?.......i would say it sounds like your sending unit went bad......you can always undo the batery for 5 minutes and let the comuter reset, maybe that will do something sometimes these cars are weird. if that doesnt work i would say its your sending unit and it will need to be replaced......or it could be the guage itself......give the old dashboard a tap or two...

  3. #3
    Oh No! Its the Cops 95Fyrebyrd's Avatar
    Join Date
    Jan 2008
    Location
    Columbus, Oh
    Posts
    164

    turquoise
    1995 Firebird

    i replaced the oil filter, when i whent to dispose my old oil at jiffy lube they told me the oil filter could have a double gasket on it. I was gonna check it out today but had to work, plus it rained kinda hard here. I really dont wanna drain the fresh oil i put in there. Could the sending unit go bad right after an oil change. Everything was fine, untill i put the fresh oil in it. I was thing maybe i might have taped the sensor for the oil, but im not sure where its at nor wut it looks like. I have to get a tune up on it. I think im just gonna take it to the mechanic and see what he has to say about it. If i cant find the problem myself.

  4. #4
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    There are a few things to check, yea remove the filter and make sure it is seated properly and the old gasket came out. Get a mechanical gauge and replace the sender with that, that will rule out the sender if it is bad or not.

    but first and foremost do not drive the car any till you get this sorted out, if you are lucky you haven't damaged anything yet, at least not seriously. Another reason for draining the oil.

  5. #5
    Sofa King we Todd did
    Join Date
    Aug 2007
    Location
    S. Florida
    Age
    41
    Posts
    164

    Black
    1990 Firebird

    The oil pressure sensor is the black cylindrical thing cmming out of the oil filter housing, just above the oil filter. They break real easy if bumped sideways, specially if it's original. They are available at the parts store for about $20. My guess is you unplugged it, or broke it if bumped.

    This is contingent on the oil level itself not dropping.
    3.4/3500 Twin Turbo almost complete
    I have CNC machines, contact me if you need something. 3500 top ends available.

    -John

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: oil pressure
    By Z28boy2000 in forum General Help
    Replies: 16
    Last Post: 07-14-2009, 08:32 AM
  2. Help: Oil pressure goes down!??
    By 98T/A.SNAKEATER_ in forum General Help
    Replies: 15
    Last Post: 11-02-2008, 07:08 AM
  3. Replies: 3
    Last Post: 04-01-2006, 04:59 PM
  4. Looking for gauges! nitrous pressure, fuel pressure!
    By texasss in forum Parts Wanted / Trade
    Replies: 2
    Last Post: 10-29-2005, 10:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •