Results 1 to 15 of 15

Auto Transmission shifts hard from 2to3 under WOT

This is a discussion on Auto Transmission shifts hard from 2to3 under WOT within the V6 forums, part of the Vehicle Specific category; I've noticed my transmission shifting very hard under WOT. It's like a hesitation and then a hard shift. It's got ...

  1. #1
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    Auto Transmission shifts hard from 2to3 under WOT

    I've noticed my transmission shifting very hard under WOT. It's like a hesitation and then a hard shift. It's got me concerned. I checked the fluid, it's got the right level in it and the fluid looks brand new. Any ideas to help me diagnose the problem?

  2. #2
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Is this recent? My 98 always shifted pretty hard going into 3rd.

  3. #3
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    Quote Originally Posted by tatertot91 View Post
    Is this recent? My 98 always shifted pretty hard going into 3rd.
    Well I just got the car, so I just noticed it. The only code it throws is the MAF. I don't know jack about auto transmissions.

  4. #4
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    buy some CRC MAF cleaner at your auto store and clean the MAF
    That isn't a code you want
    Dirty/faulty maf could cause your car to run all kinds of crazy you don't want

  5. #5
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    I did forget some details.

    After getting the code read i pulled the MAF out to inspect it. It was very clean, almost new looking. I also inspected the screen, because I'm thinking a build up of oil/debris would mean it had a k&n filter on it and the oils from that got on the MAF. But, like i said, the MAF looked spotless.

    Big question is, would the MAF being faulty do something to the ECU to make the shift points fk up?

    These transmissions must have a filter under the pan, right? If that filter was in need of a change would it cause that?
    I hate transmissions

  6. #6
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Slow roll up hill slip when just giving it a little gas? Time to have the trany scanned and reprogrammed.. Mine slipped @ 26k.. Had it reprogrammed 4-5 years ago.. No trouble since.. Also if you're doing a trany fluid change, I recommend have it flushed and a filter change.. That way you can get all the crap out of the converter too. Also the MAP sensor directly effects the 3800-II f-body trany and fuel pressure regulator.. Which effects fuel (delivery) psi, and the trany line pressure under over rev conditions..
    Last edited by Smittro; 08-24-2010 at 08:18 AM.
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  7. #7
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Could try pulling the MAP sensor and cleaning out the junk that's most likely built up inside the lower (small piece that the MAP clips into, made of black plastic) housing (2 torx to remove).. I don't recommend digging around in the small "breather" hole in the MAP itself tho.. If the small hole is clogged or has debris in it,, replace it.. The MAP sensor is part of the speed density side of our ECM's.. It works in concert with the MAF and IAT to adjust fuel delivery based on the readings between the sensors.. o2 included.. A problem @ the delivery level will have system wide effects including effects on the trany.. If there's a problem with the MAF, the ECM could be in SD mode, or even "limp" mode.. Like I said it does'nt matter what or how the sensor "appears".. You need a scanner, or tuning software to make any real determination of MAF proper operation.. If your MAF checked out bad it probably is.. As stated earlier, bad MAF can have system wide effects, cluding trany.. Good Luck
    Last edited by Smittro; 08-24-2010 at 08:42 AM.

  8. #8
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    Quote Originally Posted by Smittro View Post
    Could try pulling the MAP sensor and cleaning out the junk that's most likely built up inside the lower (small piece that the MAP clips into, made of black plastic) housing (2 torx to remove).. I don't recommend digging around in the small "breather" hole in the MAP itself tho.. If the small hole is clogged or has debris in it,, replace it.. The MAP sensor is part of the speed density side of our ECM's.. It works in concert with the MAF and IAT to adjust fuel delivery based on the readings between the sensors.. o2 included.. A problem @ the delivery level will have system wide effects including effects on the trany.. If there's a problem with the MAF, the ECM could be in SD mode, or even "limp" mode.. Like I said it does'nt matter what or how the sensor "appears".. You need a scanner, or tuning software to make any real determination of MAF proper operation.. If your MAF checked out bad it probably is.. As stated earlier, bad MAF can have system wide effects, cluding trany.. Good Luck
    OK, I am convinced. I'll be going to O'reillys this week to pick one up.
    Thanks

  9. #9
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    Wierd, just got back from a ride. The Check engine light is off now, but the surge/bumpy shift is still there. Even when it's not under full throttle. idk. Transmissions suck.

    I'm wondering if I need to bring it to the stealership. I'm not sure there's a transmission shop for 100 miles.

  10. #10
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    btw, this is the second time the check engine light has turned off. I'm going to wait an hour or so and try again to see if it's back on.

  11. #11
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    What is the tranny code (name for it)? I'll do a few more searches on it.
    Auto 4

  12. #12
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by mroby View Post
    What is the tranny code (name for it)? I'll do a few more searches on it.
    Auto 4
    3800-II (auto) Non-y87 cars got the "MXO", and y87's like mine got the M30.... The 5spd is an M49...

  13. #13
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by mroby View Post
    Wierd, just got back from a ride. The Check engine light is off now, but the surge/bumpy shift is still there. Even when it's not under full throttle. idk. Transmissions suck.

    I'm wondering if I need to bring it to the stealership. I'm not sure there's a transmission shop for 100 miles.
    Quote Originally Posted by mroby View Post
    btw, this is the second time the check engine light has turned off. I'm going to wait an hour or so and try again to see if it's back on.
    Possibly a catalyst inefficientcy starting.. If your seeing a rich condition the cat can be damaged if exposed to raw/unburned fuel for periods of time.. All points back to the MAF issue as well as the driveablity issues.. Also just because the light goes out, does'nt mean it "ok" now.. The ECM is keeping a log of each event and will soon trigger a steady SES light .. After the proper repair the ECM will clear the code after a few start up and shut downs...

  14. #14
    Junior Member
    Join Date
    Jul 2010
    Location
    Louisiana
    Age
    35
    Posts
    60

    Black
    2002 Camaro v6

    Quote Originally Posted by Smittro View Post
    Possibly a catalyst inefficientcy starting.. If your seeing a rich condition the cat can be damaged if exposed to raw/unburned fuel for periods of time.. All points back to the MAF issue as well as the driveablity issues.. Also just because the light goes out, does'nt mean it "ok" now.. The ECM is keeping a log of each event and will soon trigger a steady SES light .. After the proper repair the ECM will clear the code after a few start up and shut downs...
    I will be getting a new MAF ASAP. Then I'm going to delete the cats. I haven't searched yet but I'm sure it wouldn't be too hard to find an O2 sim for it.

    Yes, I'm on the same page with you about the light going off and coming back on.

  15. #15
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Thumbs up

    Quote Originally Posted by mroby View Post
    I will be getting a new MAF ASAP. Then I'm going to delete the cats. I haven't searched yet but I'm sure it wouldn't be too hard to find an O2 sim for it.

    Yes, I'm on the same page with you about the light going off and coming back on.
    02 sims are a waste of money and are'nt known for their reliablity.. Best to have the rear 02 tuned out.. Running without a cat will through a cat code, but will NOT effect the vehicles performance.. The front 02 sensors are the important ones for the AFR's..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Hard first shift otherwise shifts very smooth
    By 79TransAm in forum Automatic Transmission
    Replies: 2
    Last Post: 06-21-2012, 06:34 PM
  2. Hard Shifts
    By tatertot91 in forum Manual Transmission
    Replies: 7
    Last Post: 07-31-2010, 09:27 PM
  3. Tranny shifts hard during WOT
    By Anwazi in forum Automatic Transmission
    Replies: 3
    Last Post: 04-23-2008, 12:11 PM
  4. it shifts sooo hard
    By silverz28camaro in forum Automatic Transmission
    Replies: 5
    Last Post: 04-16-2007, 07:31 AM
  5. Aftermarket auto shifts/knobs??
    By jeffsredt/a in forum Automatic Transmission
    Replies: 0
    Last Post: 03-29-2006, 03:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •