Page 1 of 2 12 LastLast
Results 1 to 20 of 30

03 grand am gt horrible fuel mileage

This is a discussion on 03 grand am gt horrible fuel mileage within the V6 forums, part of the Vehicle Specific category; got some questions, or need some help in this area. my wife has a 03 grand am gt with the ...

  1. #1
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    03 grand am gt horrible fuel mileage

    got some questions, or need some help in this area. my wife has a 03 grand am gt with the 3.4 liter in it. has 90k miles on it. we took it on a trip last week and i noticed how horrible it is on fuel mileage. we took it on a trip which was 200 miles and it literally took over 3/4 of a tank of gas to get us there. so i filled the car up and reset the trip and drove ti to see how far it will go on a tank of gas it will go 285 miles on a tank of gas until the low fuel light comes on....even my maro will go 200miles on half a tank of gas. so im puzled as to why we cant get the mileage out of it. the car isnt thrwoing any codes at all, doesnt spit,sputter,shake or shutter, so i dont know where to even start here. any ideas would be helpful at this point

  2. #2
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by SteveCZ28 View Post
    got some questions, or need some help in this area. my wife has a 03 grand am gt with the 3.4 liter in it. has 90k miles on it. we took it on a trip last week and i noticed how horrible it is on fuel mileage. we took it on a trip which was 200 miles and it literally took over 3/4 of a tank of gas to get us there. so i filled the car up and reset the trip and drove ti to see how far it will go on a tank of gas it will go 285 miles on a tank of gas until the low fuel light comes on....even my maro will go 200miles on half a tank of gas. so im puzled as to why we cant get the mileage out of it. the car isnt thrwoing any codes at all, doesnt spit,sputter,shake or shutter, so i dont know where to even start here. any ideas would be helpful at this point
    You could try some CRC on the MAF, then do plugs and wires.. I'd still take it and have it scanned.. Could be a intermittent code that's not triggering the SES light.. Cat could be starting to crap out too.. I hate sequential injection.. Batch fire (tuned port) was so much more reliable back in the day. Maybe change the MAP sensor too... They don't get the greates mgp's to begin with tho but that does sound off a bit.. I get roughly 300 miles from a tank of premium in the 3800 Camaro.. You should do @ least a little better than that tho with less cudes and the 3.4 ohv being a more efficiant engine in general.. Check tire pressures and brakes for maybe a slight hang.. That's all I can think of right now.. Let me know if you need more help, I can dig into the manuals if needed..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  3. #3
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    yea i did all the brakes all the way around 2 weeks ago...left rear rotor/pads were shot, but for it to still have shitty mileage is beyond me...ill clean the maf, and see how that is, and maybe pull a few random spark plugs and see how they look

  4. #4
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    cleaned maf, and checked plugs. pulled all 3 in the front they look new, as in they had been serviced recently. and they all had fresh grease on the boots

  5. #5
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Well you prolly did the air cleaner then too. I'm @ a loss @ what could be causing it.. I think you should be getting between 22-24ish mpg's or better so there has to be something we are missing here.. Maybe try some injector cleaner. Could even be water in your tank, bad batch of gas just guessing @ this point.. Could be a trans issue starting.. Is the converter locking up like it should ? (if you noticed) Or shifting right? I'm trying to come up with a possible cause.. But is there any noticable power loss when cruising? Any highway speed bucking or misfiring?

  6. #6
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    yes checked the filter, it was clean...i knocked some of the loose stuff out (bugs, bigger particles and what not) doubt theres water in the tank as its been getting shitty mileage for a while (wife just told me, i just noticed on the trip we took) transmission still acts fine, doesnt hold gears longer than it should, doesnt slip, doesnt bang into gear when actually shifting it into gear, and doesnt have hesitation either when putting it in gear. torque converter still locks up just fine. and locks up when temp gauge is about 1/4 the way up everytime. no power loss when driving, doesnt spit or sputter at highway speeds either, and still plenty of power when u stomp on it, will light the tires up

  7. #7
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    Quote Originally Posted by SteveCZ28 View Post
    yes checked the filter, it was clean...i knocked some of the loose stuff out (bugs, bigger particles and what not) doubt theres water in the tank as its been getting shitty mileage for a while (wife just told me, i just noticed on the trip we took) transmission still acts fine, doesnt hold gears longer than it should, doesnt slip, doesnt bang into gear when actually shifting it into gear, and doesnt have hesitation either when putting it in gear. torque converter still locks up just fine. and locks up when temp gauge is about 1/4 the way up everytime. no power loss when driving, doesnt spit or sputter at highway speeds either, and still plenty of power when u stomp on it, will light the tires up
    its funny that my z28 gets better mileage, and has 126k on it. im getting anywhere from 315-375 per tank in it

  8. #8
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Unhappy

    Quote Originally Posted by SteveCZ28 View Post
    yes checked the filter, it was clean...i knocked some of the loose stuff out (bugs, bigger particles and what not) doubt theres water in the tank as its been getting shitty mileage for a while (wife just told me, i just noticed on the trip we took) transmission still acts fine, doesnt hold gears longer than it should, doesnt slip, doesnt bang into gear when actually shifting it into gear, and doesnt have hesitation either when putting it in gear. torque converter still locks up just fine. and locks up when temp gauge is about 1/4 the way up everytime. no power loss when driving, doesnt spit or sputter at highway speeds either, and still plenty of power when u stomp on it, will light the tires up
    You got me then.. Can't think of any other reason for the crappy mileage...

  9. #9
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    weird...might just clean it up and sell it then

  10. #10
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by SteveCZ28 View Post
    its funny that my z28 gets better mileage, and has 126k on it. im getting anywhere from 315-375 per tank in it
    Gets better mileage than my 3800 too.. I get about 300 per tank full of premium..

  11. #11
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Unhappy

    Quote Originally Posted by SteveCZ28 View Post
    weird...might just clean it up and sell it then
    Maybe try a couple tanks of premium.. That's about all I got..

  12. #12
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Quote Originally Posted by SteveCZ28 View Post
    uhm wow....thanks for completly steering my topic off course..i made this for help on my wifes car, not to hear what everyone else gets for mileage
    Cleaned up, lets keep this on the original topic to help the OP.

  13. #13
    Lifes A Garden, Dig It!!! 02convertibleT/A's Avatar
    Join Date
    Jun 2009
    Location
    Northern Ohio
    Posts
    169

    Pewter
    2002 Trans Am Convertible

    i owned a GAGT for a while. had a 2000 GT Coupe. MPG was around 17 average. 20 highway. i wasnt getting more than 240 when the low light came on.

    Dont forget, if you dont know already, about the intake gaskets.

    even after my tune up. PCV, Plugs, Wires, Belt, it was getting the same gas mileage.

    i miss that car. that car was gettin the chicks in high school!!!

    Last edited by 02convertibleT/A; 08-30-2010 at 11:57 AM.

  14. #14
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    havent figured it out...were gonna try to get the car paid off here real quick, then unload it somehwere

  15. #15
    Lifes A Garden, Dig It!!! 02convertibleT/A's Avatar
    Join Date
    Jun 2009
    Location
    Northern Ohio
    Posts
    169

    Pewter
    2002 Trans Am Convertible

    Quote Originally Posted by Smittro View Post
    That body style put the GAGT back on the map. imho best body style ever offered..
    my favorite style also!!! Pontiac did good with the Grand Am and Prix. The wider body stytles really hit the mark! i miss the car, hes selling it and i wouldnt mind getting it as a back up car, and a winter car for my GF when we store the mustang. i got so much azz in that car back in high school. haha. but, i had to stop playin sports to pay for it, and i was on track to a very nice baseball career. So i can basically say it kinda ruined my life, but it was my own fault. shouldve stuck with my 92 2.2L cavalier that was a tank and stuck with baseball. (enough of my rant) lol.

    although a G6 coupe with the 3.9 is pretty sweet!!!! E-shift, nice lookin dash, and leather! not a huge fan of the GXP styling with the big grille and spoiler.

  16. #16
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by Smittro View Post
    Probably your best bet I hate to say.. The 4t60e and the 4t65e are junk trannies right out of the box.. It may soon bite you.. The differential areas of the case are weak and will sometimes let the diff bind and out comes the CV joint or it may even start to toast a wheel bearing as a sign of internal trany problems I mentioned.. Also the friction material used is anything but good from the factory.. Even the HD units are super weak.. Ask meh how I know dis..lol
    Agreed there! The tranny is horrible on these cars. My mom has a 99 GA and it's on its second engine with the original transmission. It has around 135k on it and for some reason if you cut the wheel to sharp the low track light comes on and the tranny starts slipping. It completely misses 1st gear from a dead stop but it only does it randomly. If you haven't replaced the transmission do it now before it goes out like smittro said.

  17. #17
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    wow, i love all the stories yet again, that in no way shape or form help me with the indentification of my crappy fuel mileage...

  18. #18
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by SteveCZ28 View Post
    wow, i love all the stories yet again, that in no way shape or form help me with the indentification of my crappy fuel mileage...
    Posts removed....

    Good luck in your quest for mpg's....

  19. #19
    Junior Member
    Join Date
    Sep 2010
    Location
    warren michigan
    Posts
    8

    sapph. lt. blue metallic
    91 pontiac grand prix gt

    the 3400s get horrible gas milage once they hit 50k miles.... when i had my 2000 GAGT1 it only got 16 mpg... and like yours there was nothing wrong with it.... oh and it only had 106k miles when i sold the car....so not far off what yours is....

    edit... its a common problem with grand ams... they get bad gas milage....really nothing can fix the problem except getting a 4 cylinder.... lol
    Last edited by stonemason90; 09-07-2010 at 11:11 PM.

  20. #20
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by stonemason90 View Post
    the 3400s get horrible gas milage once they hit 50k miles.... when i had my 2000 GAGT1 it only got 16 mpg... and like yours there was nothing wrong with it.... oh and it only had 106k miles when i sold the car....so not far off what yours is....

    edit... its a common problem with grand ams... they get bad gas milage....really nothing can fix the problem except getting a 4 cylinder.... lol
    Umm what??

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Fuel mileage
    By LS1_ws6 in forum Firebird / WS6
    Replies: 28
    Last Post: 04-21-2010, 02:13 PM
  2. Help: Horrible gas mileage/brakes squill hardcore
    By izzhemp in forum Firebird / WS6
    Replies: 21
    Last Post: 02-23-2010, 08:27 AM
  3. Fuel mileage
    By croslod in forum General Help
    Replies: 34
    Last Post: 10-22-2009, 02:29 PM
  4. Horrible Gas Mileage And Rough Driving
    By AF1Strider in forum External Engine
    Replies: 29
    Last Post: 10-23-2007, 09:56 AM
  5. fuel mileage 06 lbz
    By Wyoming T/A in forum GM Trucks
    Replies: 3
    Last Post: 04-14-2006, 09:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •