Results 1 to 5 of 5

Whats wrong with my new brakes?

This is a discussion on Whats wrong with my new brakes? within the Suspension and Handling forums, part of the General Help category; So yesterday i did new rotors pads etc. And i noticed that my brake pad on my front passenger side ...

  1. #1
    - STOCK ish - Sarge91's Avatar
    Join Date
    Apr 2008
    Location
    Fairhope, Alabama
    Age
    26
    Posts
    779

    Black
    2002 Camaro SS SLP

    Whats wrong with my new brakes?

    So yesterday i did new rotors pads etc. And i noticed that my brake pad on my front passenger side is not making the same amount of contact as the driver front. First pic is the driver rotor and the contact area of pad, and the 2nd pic is the contact area of passenger pad. I know they are on all the way, and i look at it and looks like the pad is flat on there.

    Any ideas?
    2002 Camaro SS A4 - SLP# 2951 l MS4 l LT's w/ORY l F.A.S.T 78 & TB l Borla l Cutout l CME l TCI 3500 l 3.23's l !emissions l !sway

  2. #2
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Looks like one of your caliper pins is either seized or hanging up. You did remember to use high temp grease on the pins right? Could also be due to a caliper piston hanging up or sticking..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  3. #3
    - STOCK ish - Sarge91's Avatar
    Join Date
    Apr 2008
    Location
    Fairhope, Alabama
    Age
    26
    Posts
    779

    Black
    2002 Camaro SS SLP

    Quote Originally Posted by Smittro View Post
    Looks like one of your caliper pins is either seized or hanging up. You did remember to use high temp grease on the pins right? Could also be due to a caliper piston hanging up or sticking..
    Uhh, caliper pin? Haha sry i prob know what it is but im not picturing it. I know that i didnt grease it though.

    But @ work i looked at my brakes and on that front passenger rotor, the inside pad is making full contact.. so hmm.. and also on the back left "Back Driver" the inside pad is doing the same thing as the Front passenger outside pad.

    So is the pin what, where? I can grease it and check stuff tomorrow since im off.

    Thanks

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by Sarge91 View Post
    Uhh, caliper pin? Haha sry i prob know what it is but im not picturing it. I know that i didnt grease it though.

    But @ work i looked at my brakes and on that front passenger rotor, the inside pad is making full contact.. so hmm.. and also on the back left "Back Driver" the inside pad is doing the same thing as the Front passenger outside pad.

    So is the pin what, where? I can grease it and check stuff tomorrow since im off.

    Thanks
    There are 2 pins that the calipars slide in and out on as the brakes are applied and released. They require high temp grease to keep them from seizing up. If one of them is hung up and the other can move the brakes will not work effectively.. Basicly one side sticks causing the brake pads to ride against the rotor crooked..
    Last edited by Smittro; 02-08-2010 at 06:08 PM.

  5. #5
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    These:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can someone tell me whats wrong with this LS2
    By LS2SS in forum General Help
    Replies: 8
    Last Post: 10-16-2013, 07:41 PM
  2. Umm... I don't know whats wrong??
    By WS6Dream in forum General Help
    Replies: 1
    Last Post: 03-30-2011, 05:33 PM
  3. Help: Whats wrong?
    By TruThug in forum Firebird / WS6
    Replies: 20
    Last Post: 01-27-2011, 07:01 PM
  4. Question: Whats wrong with my T/A?
    By Dann in forum Firebird / WS6
    Replies: 8
    Last Post: 06-03-2009, 08:45 AM
  5. whats wrong
    By huggerls1 in forum General Help
    Replies: 5
    Last Post: 01-10-2009, 09:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •