Page 1 of 2 12 LastLast
Results 1 to 20 of 21

What the F##K is squeeking?!?

This is a discussion on What the F##K is squeeking?!? within the Suspension and Handling forums, part of the General Help category; Sooo my z28 just started making squeeking sounds, it is nothing mechanical related (engine, transmission). It happens frequently when I'm ...

  1. #1
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120

    Angry What the F##K is squeeking?!?

    Sooo my z28 just started making squeeking sounds, it is nothing mechanical related (engine, transmission). It happens frequently when I'm moving, theres periods when it does squeek, and when it doesn't. I just put on new cross drilled and slotted rotors and ceramic pads on, back in September so I doubt its that, plus the squeeking has no relation to when I apply brake pressure or when I don't. It sounds like its coming from the rear, (suspension?) does anyone know what this may or might be or have had any similar experience?? Any input would be helpful brothas
    01 m6 z28 - lid / lt headers / 3' ory w no cats / flowmaster catback w 3' dmh e-cutout / nelson pcm tune

  2. #2
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    You mean when you go over bumps? start siliconing the hell out of all that is rubber

  3. #3
    Crazy Canuck ! Eugenio_SS's Avatar
    Join Date
    Jun 2002
    Location
    Montreal, CANADA
    Age
    42
    Posts
    3,190

    triple-black
    2000 CamaroSS convertible

    check for polyurethane LCA or PHR.
    Eugenio_SS
    almost stock triple-black 2000 SS convertible with 17x11s on all 4 w/ 315s at the track or on the street with 18x10.5s on all 4 w/ 315s: (1), (2)

  4. #4
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    lol...

    ill throw this up... stock LCAs

    http://s249.photobucket.com/albums/g...23-08_2133.flv

  5. #5
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120
    Quote Originally Posted by c5z28 View Post
    You mean when you go over bumps? start siliconing the hell out of all that is rubber
    yeah it does but not just bumps, even when I'm just going along a flat surface mainly. Like when the car has been sitting for a day, at first it doesn't squeek, but after a ten minute drive or if i drive it a little agressive it starts then, silicone what exactly though? just the rubber bushing connectors?? any in particular?
    Quote Originally Posted by Eugenio_SS View Post
    check for polyurethane LCA or PHR.
    what do you mean exactly, like the rubber connectors for the lcas and phr? what should i be looking for?
    Quote Originally Posted by JoshieDoom View Post
    lol...

    ill throw this up... stock LCAs

    http://s249.photobucket.com/albums/g...23-08_2133.flv
    yeah its kinda similar to that type of squeeking. I mean since theres no relation to my brakes it must be my suspension, right? Does this usually happen, it never did on my 94z, my 01 is almost at 60k does that have anything to do with it

  6. #6
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by Raoul-Duke View Post

    yeah its kinda similar to that type of squeeking. I mean since theres no relation to my brakes it must be my suspension, right? Does this usually happen, it never did on my 94z, my 01 is almost at 60k does that have anything to do with it
    If you dont want to swing for aftermarket stuff just lube up all the bushings. It will help

  7. #7
    Member
    Join Date
    May 2008
    Location
    connecticut
    Posts
    169
    mine squeaked in the cold. ive heard the rear sway bar bushing squeak alot . spray some stuff on them

  8. #8
    Member
    Join Date
    Nov 2007
    Location
    SATX
    Posts
    847

    Pewter
    2000 Trans Am

    I have the same prob... I have the non adjustable LCA's PHB and my right side squeaks. A bunch of White Lithion or Silicone grease will quiet it up.

  9. #9
    HUNTER S. THOMPSON FAN Raoul-Duke's Avatar
    Join Date
    Mar 2006
    Location
    BURBANK
    Posts
    1,120
    Quote Originally Posted by JoshieDoom View Post
    If you dont want to swing for aftermarket stuff just lube up all the bushings. It will help
    Quote Originally Posted by m1a2d3 View Post
    mine squeaked in the cold. ive heard the rear sway bar bushing squeak alot . spray some stuff on them
    Quote Originally Posted by hurraquio View Post
    I have the same prob... I have the non adjustable LCA's PHB and my right side squeaks. A bunch of White Lithion or Silicone grease will quiet it up.
    hmm so what is the best stuff to use and easiest to apply?? and i apply it on the rubber bushing connectors?

  10. #10
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Quote Originally Posted by Raoul-Duke View Post
    hmm so what is the best stuff to use and easiest to apply?? and i apply it on the rubber bushing connectors?
    Ive just replaced mine but spray white lithium grease will help...

  11. #11
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Mine was the shock mount bushings.
    I think. Stopped after I changed them, so I assume that was it.

  12. #12
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    Put the rear seat back down and drive around. Mine squeaks like crazy some times. I need to adjust the latch bolts to put a little tension on the seatback to keep it from squeaking.

  13. #13
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by Mr. Luos View Post
    Mine was the shock mount bushings.
    I think. Stopped after I changed them, so I assume that was it.
    Can you get those aftermarket? I only found those from gm and the big piece was $194 each!

  14. #14
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    And op silicone all that is rubber that you find underneath the car, I used marine grease since it stays in place under wet conditions. Pop out the lca's, panhard rod, endlinks, etc. It might help out some.

  15. #15
    Junior Member
    Join Date
    May 2009
    Location
    Framingham, Ma
    Posts
    1

    black
    2000 Chevy Camaro z28

    i'd say the first thing to do is find out whether its coming from the inside or out of your car. second, find what side. if it is from outside, try narrowing it more to a specific area. how or when does it happen more? over bumps? just straight drivin over smooth roads? sometimes a second person helps. have a person ride in the back seat lookin for the squeak, or try drivin real slow past the person so they can hear what it may be. then, get back to us...

  16. #16
    Senior Member
    Join Date
    May 2009
    Location
    Toronto
    Posts
    1,083

    SOM
    2002 SS

    Quote Originally Posted by thearborbarber View Post
    Put the rear seat back down and drive around. Mine squeaks like crazy some times. I need to adjust the latch bolts to put a little tension on the seatback to keep it from squeaking.
    exactly where my squeak is coming from. Mine does it since the tires are bad and rims probably out of balance. on the freeway at 110 km/hr and up it starts to squeak with the slight vibration.

  17. #17
    Senior Member
    Join Date
    May 2009
    Location
    Toronto
    Posts
    1,083

    SOM
    2002 SS

    mine is getting worse. It's not the seats and I replaced the wheels/tires today and it has gotten better but still there. I opened the hatch and wiggled it and not coming from there. i pushed down on the rear fender at the 1/4 panel and I hear it with the hatch open. I just got home from getting new shocks and springs installed so i doubt its the shocks. I'm going to have my buddy get in the rear and drive the car and have him narrow it down. also going to wd40 the hatch points and rear latch.

  18. #18
    Senior Member
    Join Date
    May 2009
    Location
    Toronto
    Posts
    1,083

    SOM
    2002 SS

    I got out and pushed down on the rear quarter and it is definitely coming from something in the suspension. My guess is sway bar bushing. When I get a chance I will open it all up but my driveway is out of commission atm because of construction so i'm parked across the street

  19. #19
    Member MotorDogStar's Avatar
    Join Date
    Apr 2009
    Location
    Nashville
    Posts
    105

    Green
    1994 Trans Am GTA

    This is exactully what is happening to me!!!!!!!
    "I'll gut you like a fish!"

  20. #20
    Member MotorDogStar's Avatar
    Join Date
    Apr 2009
    Location
    Nashville
    Posts
    105

    Green
    1994 Trans Am GTA

    replaced shocks and still squeaks....lubed everything....stop for about 3 weeks now sounds worse....lookin into Sway bar bushings next....any suggestions on where and what kind of these are a good buy?
    Last edited by MotorDogStar; 07-25-2009 at 10:41 PM.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Pulley squeeking
    By rajiv1998 in forum General Help
    Replies: 1
    Last Post: 09-17-2008, 12:35 PM
  2. Help: 2000 T/A Ws.6 Squeeking bad!!!
    By jpn8801 in forum Firebird / WS6
    Replies: 16
    Last Post: 06-05-2008, 11:02 AM
  3. Squeeking!
    By sk8ters501 in forum General Help
    Replies: 3
    Last Post: 12-28-2007, 06:13 AM
  4. Brakes Squeeking!
    By zul8r2002 in forum General Help
    Replies: 5
    Last Post: 08-06-2006, 11:36 AM
  5. Strange squeeking
    By Transamws686 in forum Suspension and Handling
    Replies: 5
    Last Post: 07-24-2006, 09:35 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •