Results 1 to 11 of 11

UMI drag bar... need help now!!!!

This is a discussion on UMI drag bar... need help now!!!! within the Suspension and Handling forums, part of the General Help category; so I'm almost done installing this thing. I'm to the part where I'm supposed to torque the u bolt nuts ...

  1. #1
    Member xmarkx's Avatar
    Join Date
    Mar 2010
    Location
    EAST bay area Cali
    Posts
    634

    black
    1999 camaro SS

    UMI drag bar... need help now!!!!

    so I'm almost done installing this thing. I'm to the part where I'm supposed to torque the u bolt nuts to 90ft. pounds. while I'm torquing the nuts I notice that it's starting to crush the f**king axle mount!!!! WTF?????

    what am I doing wrong???

  2. #2
    Member xmarkx's Avatar
    Join Date
    Mar 2010
    Location
    EAST bay area Cali
    Posts
    634

    black
    1999 camaro SS

    mI'm extremely disapointed.... after taking the nuts off I can see that the slots on the axle mount where the u bolts go though are almost completely caved in and the axle mount itself is slightly bulged out on the sides... I wasn't barely at 60 ft pounds when I noticed it getting warped.... wtf

  3. #3
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Sounds like its rusted to all hell. I have never torqued them down (just gomered them on) but I have had those off a few times to grease the bushings and can't really imagine how the heck they managed to cave in.

  4. #4
    Member xmarkx's Avatar
    Join Date
    Mar 2010
    Location
    EAST bay area Cali
    Posts
    634

    black
    1999 camaro SS

    heyrethey're brand new from UMI!!! they came with the bar

  5. #5
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    They are a sponsor on here I am sure they would replace them for you to keep good presence.

  6. #6
    Member xmarkx's Avatar
    Join Date
    Mar 2010
    Location
    EAST bay area Cali
    Posts
    634

    black
    1999 camaro SS

    it's just really weird because I triple checked my steps and I know I'm doing what the directions say to do....

  7. #7
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    90 ft.lbs. on the sway bar mounts? That sounds like an awful lot. That's the torque for the LCA's if I recall.

  8. #8
    Quote Originally Posted by pajeff02 View Post
    90 ft.lbs. on the sway bar mounts? That sounds like an awful lot. That's the torque for the LCA's if I recall.
    90 ft lbs is way too much, but the installer is correct... our installation instructions say that but they are incorrect, that # should not be there.

    Just tighten them as tight as you can get them with a 3/8" ratchet, They are just a 7/16" bolt and can't handle that load. Get a washer and place it under the lock washer to help spread the load so it doesn't apply anymore pressure to the slot.

    Sorry for the mix up, I just corrected the installation instructions.

  9. #9
    Member xmarkx's Avatar
    Join Date
    Mar 2010
    Location
    EAST bay area Cali
    Posts
    634

    black
    1999 camaro SS

    ...I wish I would of known that before. I'm not sure if the axle mount is even still usable anymore. the washers that came with the bushings thst are supposed to go on the u bolt under the lock washers are too small in diameter and don't even fit on the u bolt......

  10. #10
    Member xmarkx's Avatar
    Join Date
    Mar 2010
    Location
    EAST bay area Cali
    Posts
    634

    black
    1999 camaro SS

    went to the hardware store and got silver dollar sized 7/16 washers (grinded down a little flat side on each washer so they would clear the bushing bracket)
    and put 2 on each side of the u-bolt plus the lock washer and its looking alot better now

  11. #11
    Quote Originally Posted by xmarkx View Post
    went to the hardware store and got silver dollar sized 7/16 washers (grinded down a little flat side on each washer so they would clear the bushing bracket)
    and put 2 on each side of the u-bolt plus the lock washer and its looking alot better now
    Glad to hear and again I apologize about the error in the instructions. We have been manufacturing that drag bar for over a year and no one has asked or notified us about the incorrect torque setting... I guess that shows not many people read the directions

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. were to drag at
    By woody84 in forum GTO
    Replies: 1
    Last Post: 06-29-2010, 12:42 PM
  2. Pontiac Drum Brake Drag Reduction - Low-Drag Brake
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 05-04-2009, 06:40 AM
  3. The Last Drag Race at Lions Drag Strip
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 8
    Last Post: 06-29-2008, 03:38 PM
  4. drag set up ?
    By barryTA in forum Wheels and Tires
    Replies: 0
    Last Post: 01-29-2008, 12:09 PM
  5. Drag City 1/4 mile Drag Strip
    By StoreKeeper99Z28 in forum Western Members
    Replies: 3
    Last Post: 05-26-2007, 09:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •