Results 1 to 9 of 9

Sub Frame Connector Install

This is a discussion on Sub Frame Connector Install within the Suspension and Handling forums, part of the General Help category; I installed the Umi Performance 3 Point Bolt In Subframe Connectors and Adjustable Torque Arm today. Everything just fell right ...

  1. #1
    Wide Open and Sidways 00 Z28's Avatar
    Join Date
    Nov 2005
    Location
    Virginia
    Posts
    33
    2000 Camaro Z28

    Sub Frame Connector Install

    I installed the Umi Performance 3 Point Bolt In Subframe Connectors and Adjustable Torque Arm today. Everything just fell right into place and it only took about 3 hours for the entire install by myself. When i took the test drive it has the infamous "clunk" in the rear end. I assume i do not have the control arms tight enough. Any tricks or tips on getting it tight?? Any help will be appreciated. Thanks!!

  2. #2
    Junior Member Mad-Max's Avatar
    Join Date
    Dec 2005
    Location
    DELAWARE
    Age
    48
    Posts
    72

    BRIGHT RED
    2002 FIREHAWK

    Did you replace the factory LCA's? I just put on UMI's 3 pnt SFC's poly/rod LCA's and poly/rod PHB. On the rear mount of the SFC's (where the control arm bolts too) you have the tighten the heck out of the bolts (90 ft. lbs.) in order to get them from thunking. Make sure the suspension is loaded when tightening all the bolts.

  3. #3
    Wide Open and Sidways 00 Z28's Avatar
    Join Date
    Nov 2005
    Location
    Virginia
    Posts
    33
    2000 Camaro Z28

    I kept the stock LCA's. I went back through and retightened all the bolts and my buddy came over and torqued the control arm bolt to 100 ft/lbs. I drove it and the noise isn't as bad but is still there.

  4. #4
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    is that when you reverse or start forward? or both? Just curius b/c i'm about to install SFCs

  5. #5
    The Rookie
    Guest
    Post up some pics. I am wanting to add SFC's to mine soon.

  6. #6
    KWK N NUF TheKitchenSink's Avatar
    Join Date
    Mar 2006
    Location
    Arlington Heights, Illinois
    Age
    31
    Posts
    574

    NBM
    2001 Trans Am WS6

    Same, curious as to what it looks like.

  7. #7
    Wide Open and Sidways 00 Z28's Avatar
    Join Date
    Nov 2005
    Location
    Virginia
    Posts
    33
    2000 Camaro Z28

    I also have hear that a tunnel mounted torque arm will sometimes make a noise. Has anyone had this problem???

  8. #8
    Junior Member
    Join Date
    Jul 2005
    Location
    Philadelphia, PA
    Age
    53
    Posts
    33

    Black
    2000 SS

    Quote Originally Posted by 00 Z28 View Post
    I also have hear that a tunnel mounted torque arm will sometimes make a noise. Has anyone had this problem???

    I have the Spohn tunnel mounted torque arm and when i first installed it, it made a lot of noise. It turned out some of the bolts that the instructions said to leave a little loose for movement were to loose. I tightened them and it got a lot better. it still makes some noise only when going into 6th gear.

  9. #9
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    I welded mine in and still had a clunk until i re-tightened the rear bolts on either side.
    2001 SS, Its not the car its the Driver that matters....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. sub frame connector
    By zeetwentyeight in forum General Help
    Replies: 83
    Last Post: 04-28-2010, 10:09 AM
  2. Detroit Speed Subframe Connector Kit Install - Pro
    By Ed Blown Vert in forum Camaro / SS
    Replies: 0
    Last Post: 12-22-2009, 10:10 AM
  3. What do you think of SLP's SFC sub frame connector
    By BKDZ28 in forum General Help
    Replies: 5
    Last Post: 10-08-2008, 08:57 AM
  4. What for is the second connector?
    By swisscheese in forum Stereo and Electronics
    Replies: 3
    Last Post: 05-21-2008, 01:43 PM
  5. SLP Sub Frame Connector Help!
    By CJB in forum Suspension and Handling
    Replies: 5
    Last Post: 09-23-2005, 01:00 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •