Results 1 to 5 of 5

strange noise!

This is a discussion on strange noise! within the Suspension and Handling forums, part of the General Help category; whats up ls1 members.... lately i have heard some weird noise on my car, 1.. when im getting on the ...

  1. #1
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    strange noise!

    whats up ls1 members.... lately i have heard some weird noise on my car,
    1.. when im getting on the highway or tight turns around 50mph, car handles pretty good,, but i step on the gas, i hear some rubbing noises or some kinda friction on the rear of my car, it doesnt sound metal to metal, is not the tires rubbing either, what could that be? i checked everything and nothings seems to be broken or anything,

    2.. when i go over a bump or a pot hole on the road, i heard like something is lose on my suspension, either a broken shock, lose control arm, or anything broken... it keeps getting louder, again i checked everything, i cant find anything wrong,, could that be normal due the supsension parts i have?

    my mods are, relocation brackets, adj panhard bar rod/poly ends, adj lower control arms rod/poly ends , strano springs, bilsteins shocks,
    i have like 250-300 miles on this setup..


    thanks for the help!

  2. #2
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    If you're still on your 10-bolt you could be starting to drop a bearing.

    Jack and safely support your rear and check for axle end play by pulling/pushing in and out on the wheels.

    The sound you hear over pot holes could be your parking brake cable may have some slack,

    the auto adjusters don't always work like they're supposed to.

    Calipars or brake pads could be chattering aswell over bumps.

    Sounds like you like to power out of corners, check your swaybar end links for breakage also.

    Others will likely chime in on anything I'm not thinking of.

    Hows your tire pressure? Any scuffing on the inside?

  3. #3
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    thanks for the reply smittro!

    the problem was, the drivers side lca was completly lose for some reason, thats very strange! now the noise is gone... but i still feel that weird noise when i hit the gas pedal, i dont know if its the gears, or the clutc, when i feel that car has no power, when i dont feel that,, all the power is there,,,, so i dont know!!

  4. #4
    Senior Member 98maro's Avatar
    Join Date
    Feb 2010
    Location
    north bay california
    Age
    28
    Posts
    2,973

    Black
    00 camaro ss M6 #6695

    Help! I have the same problem again.
    The drivers side LCA bolts keep getting lose. What could be the problem??
    It doesn't look broken or abything.
    Any advice??

  5. #5
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Quote Originally Posted by 98maro View Post
    Help! I have the same problem again.
    The drivers side LCA bolts keep getting lose. What could be the problem??
    It doesn't look broken or abything.
    Any advice??
    Are you using the recommended torque value when tightening them? Maybe try a lock nut (nylon insert) or some lock-tite on it so it won't back off.
    It's on jackstands.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. strange noise
    By Sic vett in forum Corvette
    Replies: 1
    Last Post: 03-07-2010, 04:17 AM
  2. Strange noise when engine started
    By Varanus762x39 in forum General Help
    Replies: 6
    Last Post: 05-09-2009, 06:42 AM
  3. Hearing strange noise
    By freddy_caprice in forum Manual Transmission
    Replies: 4
    Last Post: 03-15-2009, 01:23 PM
  4. need help (strange noise on takeoff)
    By 70ssrag in forum External Engine
    Replies: 2
    Last Post: 03-06-2009, 08:38 AM
  5. Strange Noise I think its my headers
    By 7camaro7 in forum External Engine
    Replies: 21
    Last Post: 03-02-2007, 08:50 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •