Results 1 to 7 of 7

Scraping /seems lower but I didnt change anything

This is a discussion on Scraping /seems lower but I didnt change anything within the Suspension and Handling forums, part of the General Help category; I put a Spohn cross member mounted torqe arm for LT headers on about a month ago. Loss of ground ...

  1. #1
    VERITAS / AEQUITAS T/A Addicted's Avatar
    Join Date
    Jul 2009
    Location
    Ohio (Union county)
    Age
    41
    Posts
    92

    Pewter
    2002 T/A WS-6

    Scraping /seems lower but I didnt change anything

    I put a Spohn cross member mounted torqe arm for LT headers on about a month ago. Loss of ground clearance but wasnt hitting. Started today = I'm driving the same route I always do and the slighest bump in the road and whack, (Sounds terrible) but not sure if it the torque arm cause its not all scratched up. But I can see when getting into and out of the garage(driveway slopped /I never had a problem the first month) it hits on the 1/2 rise from blacktop to concrete. I cant jack it up and get under it tonight but I will soon. Any ideas why the change?

    Does temp affect anything from tire pressure to gas shocks that could have this effect?

    I installed (3months ago) Edelbrock Performer AIS Shocks front and rear (adjustable) could these have moved adjustment?

    What could have broke elsewhere to cause this change?

  2. #2
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    you need to just go over it all and see what came lose or broke. i dont see what would cange. if i had to gess at it i would think your tork arm or cross member came lose and needs redone this time with tread lock.

  3. #3
    VERITAS / AEQUITAS T/A Addicted's Avatar
    Join Date
    Jul 2009
    Location
    Ohio (Union county)
    Age
    41
    Posts
    92

    Pewter
    2002 T/A WS-6

    couldnt sleep

    OK so it was driving me nuts so I'm foregoing sleep. Got out of bed jacked it up enough to slide under and take a look. There are scrapes on the crossmember where it was hitting. Everything is tight and seems to be in place. I did try to slide under the rear end before jacking it up and I may be crazy but I could swear I had a little more chest clearance at the muffler when I was putting on the cutout. (and the closest thing to working out Ive done since then is thinking about it) I'm stumped, why is it just now starting to hit? Throw me any guess that will actually help.

    This is what Ive recently done:
    SLP air box /K&N Air Filter / SLP Sub-frame connectors / SLP 85mm MAF / SLP Cold Air Induction /Un-baffled my hood /Smooth Bellows / VaraRam Throttle Body Velocity Stack /Hyper Tech Max energy programmer for fan temp / 160 Degree Thermostat /Spohn (cross member mounted) Adj. Torque Arm for LT Headers with Del-sphere pivot joint /Strut tower brace / Edelbrock Performer AIS Shocks front and rear /“F-Body Plus” Suspension Front and Rear Poly sway bar kit & Poly Motor and Tranny Mounts /GM updated PCV Valve / Elite Engineering PCV Oil Catch Can /K&N Open Element Valve Cover Breather /TransGo High Performance Shift Kit / QTP Stainless Steel Long Tube Headers with high velocity collector /Borla Cat Back Exhaust /QTP Digital Controlled Electric 3” Cutout / SLP Y-pipe custom fit with cats deleted / EBC Ultimax drilled & slotted rotors / Hawk Performance ceramic brake pads / NGK T55-IX Plugs / Granatelli Motor Sports Plug Wires /Premium Bosch O2 sensors / AEM Wideband UEGO Controller with a Bosch O2 sensor /IPS Motorsports tune /Dyno came out 361RWHP

    (on and unrelated note I found a stight leak on the rear diff that will need addressed) I never thought I'd have so much love for something and hate it at the same time! LMAO

  4. #4
    formally 01 T/A 0verkill's Avatar
    Join Date
    Jul 2007
    Location
    San Diego ca
    Posts
    2,253

    "Arrest Me Red"
    2001 trans am

    post pics from the side and what is hitting the ground. and the diff leak is on almost all of them. i had one on mine and it only had 8k on it

  5. #5
    VERITAS / AEQUITAS T/A Addicted's Avatar
    Join Date
    Jul 2009
    Location
    Ohio (Union county)
    Age
    41
    Posts
    92

    Pewter
    2002 T/A WS-6

    the only pic I can get is the cross member hitting going into the garage, otherwise it looks normal untill i hit a bump going down the road. Ill try to get a pic but technology is not a friend of mine. A truck driver buddy of mine has a theory that its not the car at all, but rather he claims they were taught that asphalt can move up to 3" when freezing and thawing. ???

  6. #6
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Check the shocks. They may need to be set to a firmer position. Hopefully a spring didn't weaken or break.

  7. #7
    Member Blue28's Avatar
    Join Date
    Nov 2007
    Location
    Ca.
    Posts
    769

    Navy Blue
    1999 Camaro Z28

    Lightbulb

    Did you check the set screw on the IAS spring seat to make sure it wasn't loose?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: '00 Firehawk - Front bumper scraping
    By RazorHawk in forum Suspension and Handling
    Replies: 12
    Last Post: 01-19-2009, 03:11 PM
  2. You will not believe this....atleast I didnt.
    By burnws6 in forum Almost Anything Goes
    Replies: 33
    Last Post: 10-03-2007, 02:16 PM
  3. Grinding/scraping noise
    By seekice76 in forum Manual Transmission
    Replies: 0
    Last Post: 03-28-2007, 05:22 PM
  4. No he didnt....
    By KOMATOS3 in forum Almost Anything Goes
    Replies: 13
    Last Post: 01-24-2006, 05:00 PM
  5. didnt go so well
    By ninobrn99 in forum Western Members
    Replies: 23
    Last Post: 08-29-2005, 08:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •