Results 1 to 11 of 11

rear suspension rattle..is this normal?

This is a discussion on rear suspension rattle..is this normal? within the Suspension and Handling forums, part of the General Help category; hey all, ive got an adj phb, relocation brackets, adj lca's, edlbrock trq arm, stock shocks and springs. I noticed ...

  1. #1
    Senior Member Ramairgod84's Avatar
    Join Date
    Aug 2008
    Location
    peoria, az
    Posts
    1,017

    Black
    2001 WS6

    rear suspension rattle..is this normal?

    hey all, ive got an adj phb, relocation brackets, adj lca's, edlbrock trq arm, stock shocks and springs. I noticed that when i go over rough pavement like cobblestones, or the like, eventhough they'll have a smooth surface, the rear suspension will rattle as if there's something loose, and i had it all installed a few weeks ago. What could be rattling?

  2. #2
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Have you physically inspected under there to see if you can find anything that is loose? Could be that maybe something wasn't torqued down properly.

    On the adjustable PHB and LCA's, did you get bushed ends?

    Could maybe even be your TA hitting in the tunnel. Clearance on tunnel mount torque arms are nil in our cars.

  3. #3
    Senior Member Ramairgod84's Avatar
    Join Date
    Aug 2008
    Location
    peoria, az
    Posts
    1,017

    Black
    2001 WS6

    on the lca's i got polys, and on the phb i have the roto joint. the torqe arm is from edlebrock, but i remember it happening before then. i havent been able to inspect it. i had a shop put it all on since they were doing other work for me

  4. #4
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Could even be the exhaust if they had to loosen it to install some of your components. They might have relocated it a little. Check to see if you have clearance where your exhaust goes over the axle. Aftermarket exhausts can come really close to hitting the top pan hard stabilizer bar where is goes over the axle.

  5. #5
    Senior Member Ramairgod84's Avatar
    Join Date
    Aug 2008
    Location
    peoria, az
    Posts
    1,017

    Black
    2001 WS6

    ok ill check that tonight. i mean it just sounds like its all over, and rattles on these cars are a pain to pinpoint

  6. #6
    Hello
    Another suggestion for you is to go back through what it was you had the shop due and make sure that all of the hardware is tightened. If you have any other questions feel free to ask.
    Thanks
    Brad

  7. #7
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    with my spohn LCAs there is some noise.............comes with the territory

  8. #8
    Chief of his tribe! LSCyaL8R's Avatar
    Join Date
    Mar 2008
    Location
    NYC
    Posts
    1,460

    Navy Blue Metallic
    2000 T/A Firehawk M6

    with my new LCA's there is a little noise as well. Unless it sounds nearly catastrophic there is probably not much to worry about. Get under there and torque everything down nice and tight and get back on the road. See if it improves.

    As for mine? Installed, drove, retorqued and even now if I have the windows open i can hear a little noise. A slight squeak here or rattle there. Car actually has a smoother ride and much better handling so no complaints from me over a little noise lol

  9. #9
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Check for broken sway bar linkages..
    :\Users\Steven\Pictures\d6ftg5nh.gif


    Suggestion: If you are particularly irritated by another member's posting habits and are constantly fighting the urge to flame them, you can click on that person's profile, and select "Add to ignore list." This will make that person's posts invisible to you.

  10. #10
    Senior Member Ramairgod84's Avatar
    Join Date
    Aug 2008
    Location
    peoria, az
    Posts
    1,017

    Black
    2001 WS6

    ok. lscyal8tr, my lca's are new and are the single adjustable. it makes sense now about a little rattle. when i take the car back next week to get the shocks/sways/springs put on ill have them retorque everything down

  11. #11
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rattle in the middle or rear
    By Guerrillakilla13 in forum General Help
    Replies: 48
    Last Post: 02-05-2014, 12:48 PM
  2. Front Suspension Work / Completed Rear Suspension
    By bhunter0830 in forum Suspension and Handling
    Replies: 32
    Last Post: 07-02-2013, 02:23 PM
  3. Front Suspension Work / Completed Rear Suspension
    By bhunter0830 in forum Suspension and Handling
    Replies: 0
    Last Post: 04-13-2013, 06:44 AM
  4. Suspension Rattle At Slow Speed
    By knappbunch in forum Camaro / SS
    Replies: 1
    Last Post: 08-14-2008, 03:36 PM
  5. How much rear axle play is normal????
    By LowSS in forum Drivetrain
    Replies: 0
    Last Post: 07-16-2007, 09:20 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •