Results 1 to 6 of 6

Rear end squeaking

This is a discussion on Rear end squeaking within the Suspension and Handling forums, part of the General Help category; Anyone out there help me with this? It is an up and down squeak. I have replaced the shocks, swaybar ...

  1. #1
    Junior Member
    Join Date
    May 2007
    Location
    Spring Tx
    Posts
    3

    Silver
    1999 Corvette

    Rear end squeaking

    Anyone out there help me with this? It is an up and down squeak. I have replaced the shocks, swaybar connectors, put anti seeze on all the rubber components, driven the car without the sway bar and the rear end still squeaks. I'm thinking maybe the rubber where the rear shock ties into the frame.

  2. #2
    Junior Member RedMetal's Avatar
    Join Date
    Jun 2006
    Location
    Arnaudville, LA
    Age
    44
    Posts
    78

    Bright Rally Red
    01 Camaro SS M6

    Quote Originally Posted by Gary View Post
    I'm thinking maybe the rubber where the rear shock ties into the frame.
    That is what happened to me after installing my Adj-TA and setting it at -3 degrees. The rubber bushings between the shock post and the frame get worn and before you know it the shock post is rubbing the frame and sounds like a straw going up and down in a McDonalds cup...will drive you f'n nuts! I think jegs sells new shock bushings/rubber.

  3. #3
    Member crapyboy750's Avatar
    Join Date
    Dec 2006
    Location
    Texas
    Age
    28
    Posts
    103

    Pewter
    01 Camaro SS

    When the rear end of my car squeaks i just spray some wd 40 on all of the moving and rubber parts and that helps me until the undercarriage gets wet.

  4. #4
    Junior Member
    Join Date
    May 2007
    Location
    Spring Tx
    Posts
    3

    Silver
    1999 Corvette

    Squeaking

    Thanks to both of you.

    Gary

  5. #5
    Member Speed Psychosis's Avatar
    Join Date
    Dec 2007
    Location
    Virginia
    Age
    28
    Posts
    499

    Red
    98 T/A M6 w/lid and LM1

    I have heard that subframe connectors stop a lot of squeaks and it improves handling so you might want to try that...

    EDIT: Not sure if they are made for the corvette though.

    I'd either PM or better yet call Sam Strano. He knows a lot about suspension.

  6. #6
    I Like It Stroked 99Ls1fever's Avatar
    Join Date
    Aug 2007
    Location
    Greeley,Co
    Posts
    1,006

    Artic White
    1999 Z28 408 Stroker M6

    Quote Originally Posted by Gary View Post
    Anyone out there help me with this? It is an up and down squeak. I have replaced the shocks, swaybar connectors, put anti seeze on all the rubber components, driven the car without the sway bar and the rear end still squeaks. I'm thinking maybe the rubber where the rear shock ties into the frame.
    did you grease everything before and after install? Could be that?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Squeaking....
    By flybird in forum Firebird / WS6
    Replies: 10
    Last Post: 04-06-2011, 02:56 PM
  2. 'squeaking’ going on in my rear bad
    By MotorDogStar in forum Firebird / WS6
    Replies: 8
    Last Post: 07-02-2009, 12:09 AM
  3. Squeaking Sound
    By Fade2Black in forum General Help
    Replies: 8
    Last Post: 11-14-2007, 02:42 PM
  4. Squeaking noise
    By garver in forum Firebird / WS6
    Replies: 4
    Last Post: 10-23-2007, 02:10 PM
  5. Squeaking sound?
    By bgable in forum General Help
    Replies: 3
    Last Post: 07-05-2007, 10:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •