Results 1 to 3 of 3

Is this a Problem? UMI PHB Rod End

This is a discussion on Is this a Problem? UMI PHB Rod End within the Suspension and Handling forums, part of the General Help category; I recently purchased several suspension pieces from UMI, their double adjustable PHB being one of them. Out of the box ...

  1. #1
    Junior Member
    Join Date
    Nov 2005
    Location
    VA
    Posts
    9

    Is this a Problem? UMI PHB Rod End

    I recently purchased several suspension pieces from UMI, their double adjustable PHB being one of them. Out of the box I noticed that one of the adjustable rod ends is missing some of the bushing material around the outer perimeter. I have included a picture to show the area I am concerned about. I just want to know if this could cause problems in the performance of the PHB.

    Thanks for the help!


  2. #2
    2004 HEAD/CAM CTS-V 9t8z28's Avatar
    Join Date
    Oct 2006
    Location
    doylestown, Pa
    Posts
    6,818

    SILVER
    2004 CTS-V

    All I see is a frog!

  3. #3
    Crazy Canuck ! Eugenio_SS's Avatar
    Join Date
    Jun 2002
    Location
    Montreal, CANADA
    Age
    42
    Posts
    3,190

    triple-black
    2000 CamaroSS convertible

    only see a frog, but if there is a manufacturer defect, UMI is great at dealing w/ customers and making things right... send them an email w/ the pic.
    Eugenio_SS
    almost stock triple-black 2000 SS convertible with 17x11s on all 4 w/ 315s at the track or on the street with 18x10.5s on all 4 w/ 315s: (1), (2)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cluth problem??? transmission problem???? please HELP!!!
    By adamblake97 in forum Manual Transmission
    Replies: 3
    Last Post: 04-07-2014, 08:34 AM
  2. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 03:50 PM
  3. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 08:51 AM
  4. Electrical/charging problem problem
    By jchcomputers in forum General Help
    Replies: 4
    Last Post: 02-23-2007, 06:59 AM
  5. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •