Results 1 to 4 of 4

poping sound

This is a discussion on poping sound within the Suspension and Handling forums, part of the General Help category; Not sure if this is the right forum for this question? I seem to have this poping sound coming from ...

  1. #1
    Junior Member *JC*'s Avatar
    Join Date
    Feb 2006
    Location
    Longwood, FL
    Posts
    70

    Bright Red
    '02 Firebird TA WS6

    poping sound

    Not sure if this is the right forum for this question?

    I seem to have this poping sound coming from the rear of the car. I know it's not the rear axle (meaning bad or chipped gears) or a u-joint. It sounds as if it coming from the forward left side control arm... But if you drive normal it never does it not even passing over a bad bump. It seems to only do it when you do a launch or take a right hand turn really hard.

    Now I'm wondering if it is the rubber bushing on the control arm? The car never did this until I installed the sub-frame connectors... Since I installed these things the car squeaks on the left hand side when ever you get in or out of the car, changing from reverse to drive and vice versa. Even over slight bumps it gives a squeak? Is this the subframe scuffing along the body as it flexs? and is this also the possible source for the poping?

    Has anyone ever noticed a problem with their sub-frames causing noises? Or a poping sound after an install?

    Your help is greatly appreciated

  2. #2
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    seeing as you live in longwood, why don't you bring it by my shop one day over on n john young pkwy.

    sounds like you have bolt in SFC. the body might be rubbing it. best thing to do is have them welded to the car. or, it could be just the rubber bushing squeaking on the body. try putting some grease on the bushing.

  3. #3
    Junior Member *JC*'s Avatar
    Join Date
    Feb 2006
    Location
    Longwood, FL
    Posts
    70

    Bright Red
    '02 Firebird TA WS6

    Quote Originally Posted by mrr23 View Post
    seeing as you live in longwood, why don't you bring it by my shop one day over on n john young pkwy.

    sounds like you have bolt in SFC. the body might be rubbing it. best thing to do is have them welded to the car. or, it could be just the rubber bushing squeaking on the body. try putting some grease on the bushing.

    Yes, they are the bolt in type. However, I don't want them weld in for various reasons but the most important reason is I want to be able to remove them for repairs...

    I've tried greasing the bushing but it does nothing to stop the squeak... The squeak is the least of my problems. It's the poping sound that disturbes me the most, I can't figure out what it is and what is causing it...

  4. #4
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    well, bring it by one day.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: These keep poping up while driving
    By Draik in forum Firebird / WS6
    Replies: 13
    Last Post: 08-10-2010, 07:43 PM
  2. poping noise
    By ls1speedster in forum Firebird / WS6
    Replies: 2
    Last Post: 12-12-2007, 04:31 PM
  3. Reverse gear poping out.
    By SPDemon81 in forum Manual Transmission
    Replies: 8
    Last Post: 06-18-2007, 07:22 AM
  4. poping in to say hello
    By zbaron in forum Firebird / WS6
    Replies: 8
    Last Post: 10-30-2006, 03:34 PM
  5. My air lid clips keep poping off
    By 1959ls1 in forum External Engine
    Replies: 10
    Last Post: 07-09-2006, 09:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •