Results 1 to 8 of 8

please help strut noise

This is a discussion on please help strut noise within the Suspension and Handling forums, part of the General Help category; ok so just installed my pro kit and one strut had the classic rust bla blah. so replaced it with ...

  1. #1
    Junior Member
    Join Date
    Apr 2008
    Location
    cincinnati
    Posts
    7

    mystic
    2000 trans am

    please help strut noise

    ok so just installed my pro kit and one strut had the classic rust bla blah. so replaced it with new and wasnt sure if i needed the gold metal peice from the stock strut it was not coming off the old strut so switched all the ruber peices and put on the new one now it makes a rattling sound when it hits a bump like somethings loose. also the back is squeaking very bad anyone ran into this before. any help
    thanks

  2. #2
    Member
    Join Date
    Sep 2006
    Location
    OKC
    Age
    34
    Posts
    210

    Artic White
    2002 ws6

    I am having the EXACT same problem. Last summer I installed the Hotchkis spring kit and ever since i've been having that problem. Two different shops couldn't hunt it down. Now it's gotten to the point that when I turn my wheel as sharp as I can and get it rolling... I hear a similar clanking sound. You might try that and see if you hear it then too. I'm dropping it off at another place in the morning. Let me know if you find anything out and I'll do the same. Good Luck!!!

  3. #3
    Member egod's Avatar
    Join Date
    Feb 2008
    Location
    Chicago
    Posts
    436

    Navy Blue Metallic
    1999 Trans Am

    I am having the same issue as well, I replaced the strut mounts, struts, springs, and perches and I getting a clanking noise when I hit bumps too. Anyone found a fix?

  4. #4
    Member SuperSSguy's Avatar
    Join Date
    Jul 2012
    Location
    NorCal
    Posts
    979

    Sunset Orange Metallic
    2002 Camaro SS M6

    Im wondering if springs are sitting in the seat properly?

  5. #5
    Member egod's Avatar
    Join Date
    Feb 2008
    Location
    Chicago
    Posts
    436

    Navy Blue Metallic
    1999 Trans Am

    i found my problem, probably after months of unsafe driving. Turns out it was my strut mounts, they were completely blown out, the metal sleeve and the rubber around it had ripped out from the rest of the mount. It was really hard to see on the car, so hard even Speed Inc in schaumburg missed it and accused my rack and pinion as the cause of the violent bumps and rattles. My car is lowered so that is why it was hard to see even on a lift, but one of the local brake shops pointed it out and a f-body speed shop could not. After i pulled them and replaced them no more rattles and rock solid. I would check that out.

  6. #6
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    I believe I have the same problem, I was going to go hunting for it soon, I will start with this. Thanks for posting.

    - - - Updated - - -

    Where did you get the replacment?

  7. #7
    Member egod's Avatar
    Join Date
    Feb 2008
    Location
    Chicago
    Posts
    436

    Navy Blue Metallic
    1999 Trans Am

    i first bought KYB strut mounts from summit. The replacements i purchased from carquest. If you jack up the car and can slide your finger between the spring to touch the bottom of the strut mount and you feel sticky rubber then its probably shot. If you take some time to pull the bottom bolts off the strut the shock with just fall out cause its not being held into the strut mount.

  8. #8
    expensive tires az gt eater's Avatar
    Join Date
    Mar 2006
    Location
    phoenix
    Posts
    1,951

    white
    04 2500 4x4 crew cab

    I will def check that out. I just recently replaced struts, ball joints, bushings, the list goes on, but not those mounts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do i need a new strut
    By cancam99ss in forum Suspension and Handling
    Replies: 7
    Last Post: 08-17-2010, 08:54 PM
  2. My new KYB strut makes a creaky noise in rain only
    By BlackZ28629 in forum Suspension and Handling
    Replies: 3
    Last Post: 11-11-2006, 08:21 AM
  3. What way does the strut go??
    By CitationZ06 in forum Suspension and Handling
    Replies: 4
    Last Post: 09-17-2006, 10:46 AM
  4. Strut Bar
    By camarostripes96 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-17-2006, 04:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •