Results 1 to 5 of 5

Noise when accelerating hard off line (recently lowered)

This is a discussion on Noise when accelerating hard off line (recently lowered) within the Suspension and Handling forums, part of the General Help category; I have lowered it 1.25" with Strano springs/Bilstein combo. I installed LCA relocation brackets, but have not installed an adjustable ...

  1. #1
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    Noise when accelerating hard off line (recently lowered)

    I have lowered it 1.25" with Strano springs/Bilstein combo. I installed LCA relocation brackets, but have not installed an adjustable panhard bar. It's fine if I take it easy. The noise was a clunking sound with the same frequency as the spinning driveshaft. I'm thinking u-joints and/or pinion angle ... and maybe the driveshaft is hitting something when the rear squats down during hard take off from a stop?

  2. #2
    024mula 024mula's Avatar
    Join Date
    Dec 2010
    Location
    Ohio
    Age
    57
    Posts
    680

    silver
    '02 Firebird Formula

    I'm no expert on this, but could it be your rear tires touching your fenders?

  3. #3
    None Shall Pass Knight's Avatar
    Join Date
    Jan 2010
    Location
    East of Cleveland, Ohio
    Posts
    3,828

    Black
    99 WS.6 - Modified

    If you lowered the car, and do not have an adjustable torque arm, your pinion angle will be off. Couple that with hard acceleration, and I'm guessing your u-joints are binding. You will need an adjustable torque arm, and set the pinion angle around -2.

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I'm with Walt on this....

  5. #5
    Member 79Firebird_99TA's Avatar
    Join Date
    Apr 2007
    Location
    ATL
    Posts
    242

    Black
    99 Trans Am

    Turns out the nut on the transmission mount was very loose. I do agree that I need a adjustable panhard bar..... ordering one today.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: noise when accelerating
    By j nix in forum Drivetrain
    Replies: 27
    Last Post: 09-25-2011, 11:41 AM
  2. noise when accelerating
    By 79Firebird_99TA in forum Automatic Transmission
    Replies: 7
    Last Post: 06-30-2011, 05:03 PM
  3. Question: rattle noise when accelerating
    By dav-02ws6-m6 in forum General Help
    Replies: 11
    Last Post: 11-28-2010, 08:28 PM
  4. Clicking noice when accelerating hard and turning.
    By CaliCruiser in forum Drivetrain
    Replies: 7
    Last Post: 01-31-2008, 08:42 AM
  5. Accelerating problem and "popping noise"
    By 94camm in forum General Help
    Replies: 2
    Last Post: 10-05-2005, 09:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •