Results 1 to 3 of 3

Need Help Spring/Strut!!!!

This is a discussion on Need Help Spring/Strut!!!! within the Suspension and Handling forums, part of the General Help category; I posted a couple others but so yesterday i installed eibach pro's and bilsteins all around. was a pain cause ...

  1. #1
    Member Camaro69Mac's Avatar
    Join Date
    Mar 2010
    Location
    Agawam Mass
    Posts
    334

    Black
    69 Camaro, 99 Camaro SS

    Need Help Spring/Strut!!!!

    I posted a couple others but so yesterday i installed eibach pro's and bilsteins all around. was a pain cause of the typical rust but once the first one was done i flew through it, rear 25 mins...anyways so i have a loud clunking coming from both sides which is killing me cause everything is tight (so i thought) couple questions. What do i have to remove from the old struts to put on the new ones???? I put the lower spring mount on and that was it. Am i missing something? also they come with a silver metal cap which i thought went on the middle of the strut. I read somewhere else it was a spring hat? what the hell is that? another thing is how tight do you put that strut mount on top? the one with the allen. if its too tight and the bolt sticks out too much will it hit the body? i hope this is enough of a description of my problem thanks for the help. i'm frustrated cause it went ok and looks amazing but now i'm pissed cause it is driving horrible!!

  2. #2
    Senior Member
    Join Date
    May 2009
    Location
    Toronto
    Posts
    1,083

    SOM
    2002 SS

    A spring hat is just that. it keeps the spring in place on the top. was the spring loose when you installed it or did you have to compress it?

    Here's a link that helped me.

    http://www.ls1howto.com/index.php?article=6

  3. #3
    Member Camaro69Mac's Avatar
    Join Date
    Mar 2010
    Location
    Agawam Mass
    Posts
    334

    Black
    69 Camaro, 99 Camaro SS

    Quote Originally Posted by 5abivt View Post
    A spring hat is just that. it keeps the spring in place on the top. was the spring loose when you installed it or did you have to compress it?

    Here's a link that helped me.

    http://www.ls1howto.com/index.php?article=6
    I had to compress it to put it in I'm really thinking balljoints I bashed the control arm upwards with a big hammer to separate them didn't hit the balljoint itself but being 11yrs old and 105 k sounds like it very annoyed but I sure as hell hope this works I want to drive it she's looking good sitting here

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Do i need a new strut
    By cancam99ss in forum Suspension and Handling
    Replies: 7
    Last Post: 08-17-2010, 08:54 PM
  2. WTB: front strut upper spring perch
    By up2nuthingud in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-26-2007, 05:14 PM
  3. Strut change
    By weinerschizel in forum Suspension and Handling
    Replies: 0
    Last Post: 04-09-2007, 06:32 AM
  4. What way does the strut go??
    By CitationZ06 in forum Suspension and Handling
    Replies: 4
    Last Post: 09-17-2006, 10:46 AM
  5. Strut Bar
    By camarostripes96 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-17-2006, 04:38 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •