Results 1 to 10 of 10

Just received my sfc's

This is a discussion on Just received my sfc's within the Suspension and Handling forums, part of the General Help category; Just got them in today hopefully I don't have clearance issues with my duals-wish me luck....

  1. #1
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Just received my sfc's

    Just got them in today hopefully I don't have clearance issues with my duals-wish me luck.







  2. #2
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Very nice...good luck! Let us know what you think once complete.

  3. #3
    Senior Member Z28_Driver's Avatar
    Join Date
    Jun 2009
    Location
    Ohio
    Posts
    1,017

    Sunset Orange Metallic
    2002 Z28 Hardtop

    What brand did you go with?

  4. #4
    Member emoFTW's Avatar
    Join Date
    Sep 2008
    Location
    Oklahoma
    Posts
    321

    black
    99 Z28

    any updates?

  5. #5
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by Z28_Driver View Post
    What brand did you go with?
    They are the umi from byunspeed
    Quote Originally Posted by emoFTW View Post
    any updates?
    Installed them and for the most part it was a sinch. The driver side where it connects over the lca was a little tough because the frame butterflied a bit and the passenger side I had to use some grunt since for any number of reasons didn't line up "just right" it was just a matter of back tracking and no problem. From jacking the car up to putting the tools away it was 1 1/2 hours. Thankfully my duals are custom I could only see clearance issues if you had the tsp duals since they flare out. You can actually see in the pics the holes where they connected in and are no where near the exhaust.

    Took it for a drive and could feel it was a bit tighter, got in this morning and I already forgot what it felt like w/o them now for my pads and i'm ready for auto x next weekend.

  6. #6
    Chief of his tribe! LSCyaL8R's Avatar
    Join Date
    Mar 2008
    Location
    NYC
    Posts
    1,460

    Navy Blue Metallic
    2000 T/A Firehawk M6

    I REALLY like your exhaust. LT's and nice thick round pipes. Looks like you have excellent clearance as well. congrats on the SFC's. I actually had the SAME issues as you the drivers side LCA gave me a bit of trouble going on and the attachment point for the passenger side front just didn't line up for some reason. I eventually wrangled it all together wasn't at all a hard job. even keeping the car loaded and level proved easier than I thought it would. although I'd never be able to get the car on my ramps again lolol thanks lowering springs!!!

  7. #7
    Senior Member Z28_Driver's Avatar
    Join Date
    Jun 2009
    Location
    Ohio
    Posts
    1,017

    Sunset Orange Metallic
    2002 Z28 Hardtop

    Quote Originally Posted by c5z28 View Post
    They are the umi from byunspeed


    Installed them and for the most part it was a sinch. The driver side where it connects over the lca was a little tough because the frame butterflied a bit and the passenger side I had to use some grunt since for any number of reasons didn't line up "just right" it was just a matter of back tracking and no problem. From jacking the car up to putting the tools away it was 1 1/2 hours. Thankfully my duals are custom I could only see clearance issues if you had the tsp duals since they flare out. You can actually see in the pics the holes where they connected in and are no where near the exhaust.

    Took it for a drive and could feel it was a bit tighter, got in this morning and I already forgot what it felt like w/o them now for my pads and i'm ready for auto x next weekend.
    Good to hear they went in easy. Thats the same brand I was looking at.

  8. #8
    Member qwk93ta's Avatar
    Join Date
    Oct 2006
    Location
    Fairfield, Ohio
    Age
    54
    Posts
    944

    Black
    00 WS6

    Get those SFCs welded in...you will be glad you did it.

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    What did you torque your front mounting plates to? I have the 2 point UMI kit and could not find a torque spec in the instructions. I used Loc-tite and tightened them pretty good, but I wasn't sure how much to go with the threaded plate.

    The reason I ask is that since the install, every now and then on an uneven road surface, I have had a small "clunk" that feels like it is eminating from the area of the right front mount. I went back and checked and they are still both tightened down pretty good.

  10. #10
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    Quote Originally Posted by pajeff02 View Post
    What did you torque your front mounting plates to? I have the 2 point UMI kit and could not find a torque spec in the instructions. I used Loc-tite and tightened them pretty good, but I wasn't sure how much to go with the threaded plate.

    The reason I ask is that since the install, every now and then on an uneven road surface, I have had a small "clunk" that feels like it is eminating from the area of the right front mount. I went back and checked and they are still both tightened down pretty good.
    I'll have to check the paper but I think it was supposed to be over 60lb ft at least on the big bolts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Received ticket in the mail should I pay for it?
    By qwik219d9 in forum Almost Anything Goes
    Replies: 66
    Last Post: 03-09-2016, 04:44 PM
  2. Help: Received the wrong manifold!!
    By joedude02 in forum External Engine
    Replies: 43
    Last Post: 04-07-2010, 05:49 AM
  3. Has anyone received this in their mail yet?
    By SiggyZ in forum Camaro / SS
    Replies: 9
    Last Post: 01-14-2007, 06:45 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •