Results 1 to 5 of 5

Installed new suspension and can't put my strut to

This is a discussion on Installed new suspension and can't put my strut to within the Suspension and Handling forums, part of the General Help category; I've installed a set of Koni 4/4 and Strano lowering springs. Now I can't put my STB back on!!!! What ...

  1. #1
    Junior Member Octavain's Avatar
    Join Date
    Aug 2008
    Location
    NW, Arkansas
    Posts
    77

    White
    1998 Camaro

    Installed new suspension and can't put my strut to

    I've installed a set of Koni 4/4 and Strano lowering springs. Now I can't put my STB back on!!!! What the heck happened, anyone else run into this problem? If so what did you do to fix it?
    -Aaron
    Mods: SLP Flowpac Cold Air Induction Package, 160 Thermo, TB bypass, SLP (Clutch, Pressure Plate, Flywhell), Skip Shift Elminator, UMI (SFC, Tower Brace, LCA, Torque Arm, Panhand Bar), no cats, Moser 9" w/ 3.89 gears, 5.0 short throw, Strano Springs, Koni single adj, '94 OEM ZR-1 wheels

  2. #2
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    What do you mean - bolts don't line up, too short, ?

  3. #3
    King 0f n00bz shady milkman's Avatar
    Join Date
    Jan 2006
    Location
    Shepherd, Michigan
    Age
    29
    Posts
    11,775

    blacker than wesleysnipes
    98' trans am

    Quote Originally Posted by DaddySS View Post
    What do you mean - bolts don't line up, too short, ?
    x2... everything should be the same length if you did it properly

  4. #4
    Junior Member
    Join Date
    Dec 2008
    Location
    Miami, Florida
    Posts
    43

    Blue
    1999 Camaro SS

    i came accross the same problem when i did my kgx with eibach sportlines get a rubber hammer and go to town after the second smack it should go it

  5. #5
    Auto Painter RyanJM's Avatar
    Join Date
    Dec 2007
    Location
    Houston, TX
    Age
    41
    Posts
    2,002

    White
    1998 Trans Am

    That's odd I installed AGX's with new style BMR springs and had no problem getting my strut brace back on
    1998 Trans Am 85k miles.
    Bolt ons, MS3 113LSA cam, Circle D Stall, Tune, Modified WS6 style hood, Full Suspension, 6000k HID's, Clear Side Markers w/ Leds, Led 3rd Brake Light and 18" AR Staggered Killer Wheels w/ BFG KDW NT's.- Weekend Toy/DD
    02 Trailblazer -Sold
    09 Ram 1500 CC - Sold
    09 Cobalt SS/TC - Sold
    13 ram 1500 LoneStar CC 4x4 - Magnaflow, K&N,and more to come-DD/Toy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Front Suspension Work / Completed Rear Suspension
    By bhunter0830 in forum Suspension and Handling
    Replies: 0
    Last Post: 04-13-2013, 06:44 AM
  2. installed some suspension parts,
    By 98maro in forum Suspension and Handling
    Replies: 24
    Last Post: 10-21-2011, 11:21 AM
  3. Replies: 11
    Last Post: 01-23-2008, 05:16 AM
  4. 1967 Pontiac Firebird Suspension Upgrade - Suspension Ascension
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 01-17-2008, 05:50 PM
  5. New front suspension installed *pic
    By Soltakr in forum Suspension and Handling
    Replies: 5
    Last Post: 04-25-2007, 08:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •