Results 1 to 16 of 16

front shocks

This is a discussion on front shocks within the Suspension and Handling forums, part of the General Help category; i finally got around to installing the front shocks (Strano Bilsteins) yesterday and keeping the stock springs. i did it ...

  1. #1
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    front shocks

    i finally got around to installing the front shocks (Strano Bilsteins) yesterday and keeping the stock springs. i did it in a shop with a friend of mine who is a mechanic. i also used to be a mechanic so the job itself wasnt very confusing. only thing is now after the install, if i hit a bump in the road with the driver side wheel, it sounds like something is loose because it will sound like a loud thump sound. passenger side wheel doesnt do this. i already checked the following things:

    1. 2 bolts from bottom of shock to lower control arm are tight
    2. 4 bolts from upper control arm to shock tower are tight
    3. balljoint bolt with cotter pin is tight
    4. everything is lined up correctly

    what could be causing this thump im hearing? also, in the instructions on ls1howto.com, i saw something about a bump stop that goes on right after the metal cap....... nowhere in my work do i remember any bump stops coming off the stock shocks and going onto the new ones. i doubt that has anything to do with it though cause im on stock springs and theres no way im bottoming out.

  2. #2
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Perhaps the the piece that sits in the spring perch? Did you install that?

  3. #3
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    i did....

  4. #4
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Swaybar endlink?

  5. #5
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    Quote Originally Posted by Joe00SS View Post
    Swaybar endlink?
    checked that too. it was loose. tightened it up..... no difference

  6. #6
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    What about the torx screws under the master that are a pain to get to?

  7. #7
    Member Joe00SS's Avatar
    Join Date
    Oct 2005
    Location
    CT
    Age
    46
    Posts
    465

    White Liquid Silver
    2000 Camaro SS/ 02 YZF-R1

    Caliper bolts? Bad shock?

  8. #8
    Member Blue28's Avatar
    Join Date
    Nov 2007
    Location
    Ca.
    Posts
    769

    Navy Blue
    1999 Camaro Z28

    Thumbs up

    It's your shock shaft nut.

  9. #9
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Thats possible, hopefully its not that. I doubt that...

  10. #10
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    checked all the bolts and the torx ones too. only bolt i havent checked is the shaft nut bolt. sure hope its not a defective shock that would suck. gonna try to get that shaft nut looked at tomorrow. hope thats all it is.

  11. #11
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    It's not too hard to take it all back out. I've done it several times already. No worries.

  12. #12
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    Quote Originally Posted by allbaugh_04 View Post
    It's not too hard to take it all back out. I've done it several times already. No worries.
    yea its not that bad just time consuming. wat i did was order a new shock tower bracket and isolator cause the old one was a little corroded looking anyway so no point in doing the work twice. should be in tonight so will install it tomorrow.

  13. #13
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    cool, hopefully it stops rattling then

  14. #14
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    thanks to everyone. installed the new shock tower mount and made sure that nut was totally tight and no more rattle. car handles and rides so much better. only thing im hoping is that the front settles back down again because it seems like its sitting higher in the front now than it did on the stock decarbons. still on stock springs.

  15. #15
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Ya, did you make sure it was compressed so you could put the nut all the way to the bottom of those threads? I'm sure you did this time.

    Sometimes it does take a while to settle, but not long...take it for a spin and it should settle pretty quickly.

  16. #16
    Member Siciliano15's Avatar
    Join Date
    Oct 2008
    Location
    NY/CT
    Age
    33
    Posts
    263

    Black
    1998 Trans Am WS-6

    Quote Originally Posted by allbaugh_04 View Post
    Ya, did you make sure it was compressed so you could put the nut all the way to the bottom of those threads? I'm sure you did this time.

    Sometimes it does take a while to settle, but not long...take it for a spin and it should settle pretty quickly.
    the nut is def all the way in now. only other thing i can think of is maybe the new shock tower braces have to take some time to settle in also. its noticeably higher though by almost an inch by the looks of it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: I have a front shocks question
    By kool-aide in forum Suspension and Handling
    Replies: 28
    Last Post: 06-08-2008, 09:26 AM
  2. Front and Rear QA1 shocks with front QA1 springs
    By 1BadCamaro in forum Parts For Sale / Trade
    Replies: 1
    Last Post: 08-09-2007, 05:16 AM
  3. front shocks
    By 1_bad_TA in forum Suspension and Handling
    Replies: 0
    Last Post: 06-19-2007, 02:32 AM
  4. 96-97 SS Front Bilstein Shocks
    By 9t8z28 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 05-04-2007, 09:57 AM
  5. LS1 Oil Pan and Front Shocks
    By AshWS6 in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 03-01-2007, 02:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •