Results 1 to 4 of 4

DSL Issues

This is a discussion on DSL Issues within the Suspension and Handling forums, part of the General Help category; Need to see some pics from anyone that has the UMI DSL #2025. I tried this weekend to install mine ...

  1. #1
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    DSL Issues

    Need to see some pics from anyone that has the UMI DSL #2025.

    I tried this weekend to install mine and my TS&P ORY is not clearing it.

    Anyone else have this issue?


    I think because the ORY was welded up long ago before I had the DSL that any tweaks in fitment must have really change the alignment. The issue is where the Y merge is, the DSL loop portion is in the same position.


    If I adjust the ORY to where it will clear I would need to cut about 6" off the pipes that connect to the headers and bend the ORY out more for clearance around the transmission.


    I got this feeling I may need to order another ORY and start over. I'll post a pic tonight to show what I'm talking about.

  2. #2
    Senior Member raynor139's Avatar
    Join Date
    Aug 2007
    Location
    Greensboro, NC
    Age
    33
    Posts
    1,319

    Pewter
    2002 Trans Am WS6 M6

    Midwest chassis has a DSL that will clear just about any exhaust out there. Hit up there website. They specialize in drag racing so most of there stuff is designed to clear just about anything.
    Mods - Lid, Skip Shift Eliminator, MGW shifter, UMI SFCs, Founders Lower Control Arms, Founders Panhard Bar, Founders Adj. Torque Arm, UMI Torque arm mount, MWC Drive shaft safety loop, KONI Yellows, Strano Springs, Strano Sway bars, UMI Upper and lower A Arms, 160 thermostat, TSP headers and TSP true duals Monster stage 2 clutch, racetronix fuel pump, Strange S60 rear axle and tune by Frost.

  3. #3
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Looks like it is supposed to clear the TSP Y-pipe setup from what their website says. Any pics of yours?

  4. #4
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    I'll get some....got busy last night.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tv issues
    By 2000redcamaro in forum Almost Anything Goes
    Replies: 15
    Last Post: 12-24-2009, 10:47 AM
  2. Q-Jet Issues?
    By pajeff02 in forum Classic Muscle
    Replies: 7
    Last Post: 09-07-2009, 01:31 PM
  3. will 20's fit on gto with no issues
    By johnjr45 in forum GTO
    Replies: 4
    Last Post: 08-11-2007, 05:48 PM
  4. PM Issues
    By schtick in forum Request and Feedback
    Replies: 0
    Last Post: 07-10-2007, 06:54 PM
  5. Having some serious issues.
    By Banshee1967 in forum Suspension and Handling
    Replies: 2
    Last Post: 03-31-2007, 08:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •