Results 1 to 5 of 5

Bolt-on Subframe Connectors Install

This is a discussion on Bolt-on Subframe Connectors Install within the Suspension and Handling forums, part of the General Help category; Are there anything that i need to know or do while install them? I puchased the UMI Bolt On Subframe ...

  1. #1
    WS9 + Y82 = Trans Am 6speedTAthistime's Avatar
    Join Date
    Oct 2007
    Location
    cincinnati, ohio
    Posts
    130

    Silver
    02 Trans am

    Bolt-on Subframe Connectors Install

    Are there anything that i need to know or do while install them?
    I puchased the UMI Bolt On Subframe Connectors.

    I was worried about body flex and such. Is there a certain spot i should put the jackstands?

    Any help would be greatly appreciated.

    thanks
    matt

  2. #2
    A trained professional volleybill's Avatar
    Join Date
    Dec 2005
    Location
    upstate NY
    Age
    63
    Posts
    95

    Black
    2001 Z28

    You can put the car up in the air when you install them, but don't tighten them all the way until the weight of the vehicle is on all 4 tires- you want the frame loaded as it normally is when you tighten them up-

    I love mine.....

  3. #3
    1 01ls1ws6's Avatar
    Join Date
    Oct 2006
    Location
    houston tx
    Age
    31
    Posts
    273

    pewter
    01 ws6

    A buddy of mine just put the front tires on ramps and jackstands under the rearend. It worked just fine. But that could be wrong, made a world of difference on his t/a

  4. #4
    A trained professional volleybill's Avatar
    Join Date
    Dec 2005
    Location
    upstate NY
    Age
    63
    Posts
    95

    Black
    2001 Z28

    I just meant that the suspension and frame should be loaded, not hanging in space- as long as the weight is carried by the wheels and axle, all is good-

  5. #5
    Member TedsB4Csled's Avatar
    Join Date
    Feb 2008
    Location
    Asheville, NC
    Posts
    475

    white
    2002 B4C

    Quote Originally Posted by 01ls1ws6 View Post
    A buddy of mine just put the front tires on ramps and jackstands under the rearend. It worked just fine. But that could be wrong, made a world of difference on his t/a
    Did it that way today! Just tighten bolts when all 4 tires are under load. Instructions suggested that is one possible way. Got UMI bolt-ons. Glad I didn't get weld-ons. Also put on a Shock Tower Brace. Wow, what a difference! Just waiting on my KYB AGX shocks
    Last edited by TedsB4Csled; 06-04-2008 at 12:16 AM. Reason: more wordsss...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. bolt in subframe connectors or sway bars?
    By mammoth713 in forum Suspension and Handling
    Replies: 42
    Last Post: 12-13-2010, 08:27 AM
  2. FS: SLP bolt on subframe connectors....local picku
    By white.lightning in forum Eastern Members
    Replies: 19
    Last Post: 06-22-2008, 02:40 PM
  3. Subframe connectors, weld vs bolt
    By kool-aide in forum Suspension and Handling
    Replies: 72
    Last Post: 11-10-2007, 04:51 AM
  4. J&M subframe connectors install
    By Z28LS1 in forum Suspension and Handling
    Replies: 0
    Last Post: 03-12-2007, 03:10 PM
  5. F/S: SLP bolt-on Subframe connectors in Omaha, NE
    By Rocky Rotella in forum Mid-West Members
    Replies: 3
    Last Post: 02-08-2006, 08:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •