Results 1 to 2 of 2

awful noise

This is a discussion on awful noise within the Suspension and Handling forums, part of the General Help category; Hey guys, I just had my stock torque arm replace with a UMI unit. Now there is an incredibly loud ...

  1. #1
    Junior Member
    Join Date
    Nov 2005
    Location
    LA
    Age
    33
    Posts
    27

    black
    1998 TA

    awful noise

    Hey guys, I just had my stock torque arm replace with a UMI unit. Now there is an incredibly loud and annoying squeeking noise, like on rubber when I decelerate, It does increase in frequency with car speed but I dont feel a vibration or anything and when accelerating the noise goes away.. I hoping this is just one of those things that goes away after awhile??

  2. #2
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    If its the kind that relocates the mounting point to a cross bar instead of the tail of the transmission they are known to make noise.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. awful noise...
    By richard head in forum Firebird / WS6
    Replies: 7
    Last Post: 05-31-2011, 11:00 PM
  2. Help: Help with noise!
    By 2001blackz28 in forum Camaro / SS
    Replies: 2
    Last Post: 04-16-2009, 04:03 PM
  3. awful mpgs
    By emotionalpiracy in forum General Help
    Replies: 31
    Last Post: 01-20-2008, 09:32 PM
  4. when you first wake up, and that god awful hangover headache hits you
    By Ice Spiral in forum Almost Anything Goes
    Replies: 1
    Last Post: 06-10-2006, 04:45 AM
  5. hostel was awful
    By Ice Spiral in forum Almost Anything Goes
    Replies: 20
    Last Post: 05-01-2006, 06:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •