Results 1 to 5 of 5

2000 Camaro Won't Align After Turning Left

This is a discussion on 2000 Camaro Won't Align After Turning Left within the Suspension and Handling forums, part of the General Help category; ...

  1. #1
    Junior Member
    Join Date
    Feb 2015
    Location
    Los Angeles
    Posts
    1

    Red
    2000 Camaro SS

    Question 2000 Camaro Won't Align After Turning Left

    A few weeks ago I hit a bump in the road going somewhat fast (it was at night), and since then my steering wheel + wheels have been acting strange.

    Say I begin driving with the steering wheel straight and the wheels aligned straight—when I make a LEFT at an intersection and straighten out after turning, the steering wheel and wheels become misaligned. The steering wheel won't return to its original position (stopping with about a 1/4th of the way to go) but the wheels will be straight.

    Here's a pic of the steering wheel's position after making a left turn and the wheels facing straight:



    If I straighten the steering wheel while driving, I veer to the right.

    BUT, if I turn RIGHT at some point after this, and bring the steering wheel back to its straight position, it "realigns" and the steering wheel is straight and the wheels are straight. That's until I make a left turn and the steering wheel is misaligned again. So, when turning right, alignment is good, turning left messes things up. I also hear what seems to be a clacking of metal sometimes when I turn left at slow speeds.

    I thought it was an alignment issue (maybe it still is?), but I just had an alignment done today at Pep Boys and it was perfectly straight—until I made a left turn. Back to the same problem. Any ideas? Should I start looking at tie rods, bushings, ball joints, and wheel bearings?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    First thing I would look at is the pinch bolt in your steering column down by the rack. It is not unheard of for them to come loose and then they wear the hole out and create play. In addition, you will want to inspect everything in the front end, starting with the tie rods. With the front end in the air, grab each tire at the 9:00 and 3:00 positions and try to rock it back and forth. If you feel any play at all something is amiss. Also, it wouldn't surprise me in the least if something was not tightened properly after your alignment...

  3. #3
    Member RONS98TA's Avatar
    Join Date
    Jan 2009
    Location
    MARYLAND
    Age
    44
    Posts
    803

    BLACK
    1998 PONTIAC TA

    Def wanna get things checked out!! It could be something serious. As mentioned above, check the steering shaft bolt. After that, check all the components aspajeff02 mentioned above. Something is a miss and you cant just "hope" it gets better. Also grab the tire at 12:00 and 6:00 to check top and bottom play. It will also check for bearing play. and lower ball joint play.
    1998 Pontiac TA, stock heads, FAST 90, FAST 90 TB, FLP LT, off road y-pipe with cat delete, flow master muffler, comp cams 54-457-11 223/231-610/617-112 LSA, Pro charger D1SC with FMIC @ 8psi, FROST tune, VIG 3200 stall, built 4l60e, snow meth kit, MOSER 12 bolt 373 gears, Derale 13900 trans cooler.

  4. #4
    Junior Member
    Join Date
    Jul 2009
    Location
    San Antonio, Tx
    Posts
    1

    White
    2001 Camaro

    I know this is a year too late but it's the rack and pinion in case you never figured it out. I had the same symptoms and my car would wander to the point where it was really unsafe. It makes no sense but I replaced my rack and pinion and it fixed it. The rest of my suspension parts were all new so that was the only thing that it could be and it was.

  5. #5
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Old thread -- looks like the OP never posted back up on what his issue was.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fender removal / re align?
    By Transam388 in forum Firebird / WS6
    Replies: 4
    Last Post: 08-30-2014, 01:29 AM
  2. My 02 ss Camaro idling ruff and feels like turning off
    By Anayalator408 in forum General Help
    Replies: 5
    Last Post: 03-25-2012, 05:02 PM
  3. Help: A4 camaro turning off problem!?!?
    By 01SsRacing in forum General Help
    Replies: 3
    Last Post: 09-20-2011, 08:59 AM
  4. OEM 16" 2000 Camaro Z28 rims/Goodyear GS-D3 8/32 tread left
    By CorvetteZ06C5 in forum Parts For Sale / Trade
    Replies: 10
    Last Post: 09-27-2010, 06:49 AM
  5. Replies: 2
    Last Post: 07-24-2007, 06:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •