Results 1 to 5 of 5

Weird noise after clutch swap

This is a discussion on Weird noise after clutch swap within the Manual Transmission forums, part of the Drivetrain category; Hi all I installed a McLeod SRT twin disc clutch in my 2001 camaro/T56. After the install the clutch works ...

  1. #1
    Member BlackSS1's Avatar
    Join Date
    Jun 2007
    Location
    Lexington, NC
    Posts
    459

    Black
    2001 Camaro SS Vert

    Weird noise after clutch swap

    Hi all

    I installed a McLeod SRT twin disc clutch in my 2001 camaro/T56. After the install the clutch works great, shifts fine, hold strong etc. Installed a new pilot bushing. I re-installed same shifter Pro 5.0.

    However at 2000-2200 RPM there is this wierd vibration/noise that you can both hear and feel in the shifter...not too harsh but definately not normal. I wonder if this is inherent in this clutch or if I made an error during install?

    Any ideas/suggestions?

    thanks!

  2. #2
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,083

    Navy Blue Metallic
    98 T/A w/a little mods...

    May just need to break in. Twin disk have a different feel over single disk.

    When I did my Monster stg 4 I had to learn all over again compared to the previous LS7 clutch. Pair that with a Tick MC and let's just say I have leg day every time I drive.

  3. #3
    Senior Member Naaman's Avatar
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    1,315

    Cayanne
    98 Z28 Vert M6

    LOL. "Leg day."

    How many miles on the install so far?

  4. #4
    Member BlackSS1's Avatar
    Join Date
    Jun 2007
    Location
    Lexington, NC
    Posts
    459

    Black
    2001 Camaro SS Vert

    It has about 2000 miles on it so far.

  5. #5
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,083

    Navy Blue Metallic
    98 T/A w/a little mods...

    Well that's past break in......


    Vibrations in the shifter can also be a tranny bushing going bad, loose housing bolts, driveshaft.

    I'd put it up on a lift and do a once over one more time. maybe talk with McLeod and see if they can offer any insight.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Weird Noise on take off
    By 01SsRacing in forum General Help
    Replies: 6
    Last Post: 09-19-2012, 01:44 PM
  2. weird noise...
    By Ramairgod84 in forum General Help
    Replies: 4
    Last Post: 04-01-2010, 11:13 AM
  3. weird f***ing noise
    By maroca in forum General Help
    Replies: 3
    Last Post: 07-23-2009, 07:54 AM
  4. Weird noise still!
    By zul8r2002 in forum General Help
    Replies: 4
    Last Post: 08-13-2006, 11:28 AM
  5. Weird noise? Clutch?
    By dkishton1486 in forum LT1
    Replies: 0
    Last Post: 02-16-2006, 08:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •