Results 1 to 5 of 5

Weak Clutch Pedal

This is a discussion on Weak Clutch Pedal within the Manual Transmission forums, part of the Drivetrain category; While driving back home, I started having an issue with my clutch. Was turning from a traffic light, and got ...

  1. #1
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    Weak Clutch Pedal

    While driving back home, I started having an issue with my clutch. Was turning from a traffic light, and got on it alittle, and right after that, my clutch felt different. It goes farther to the floor, and its tough to get it into any gear. I checked the fluid in the clutch master cylinder and it is about 1/2" below cap. Is my clutch finally going, or just out of adjustment?

    Thanks

  2. #2
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    OK, now that I have let the car cool down, I just tried driving it, and it does go in and out of gear easily. I did notice that my fluid is really dark.

    Is there anyone in the Charlotte area that has changed/flushed the fluid before? I am confident I can do it, but would like to have someone that has done it before to give a helping hand to a new member!

    Thanks,

    Mike
    1999 Camaro Z-28 LS1 M6
    Cam, Heads, Exhaust

  3. #3
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS


  4. #4
    Junior Member oharam's Avatar
    Join Date
    Feb 2011
    Location
    Tampa Bay
    Posts
    83

    Black
    1999 Z-28 LS1

    35TH, thanks for the link! Gonna have a few rainy days here next week, gonna play with it in the garage.

    Thanks again

  5. #5
    Senior Member wileyCoyote's Avatar
    Join Date
    Oct 2005
    Location
    Centerville OH
    Posts
    1,591

    blue
    1999 TransAm

    do a search on "ranger clutch fluid", there should be sone thread on here about "lazy pedal", etc. problem could be the slave cyl., which is inside the bell housing/tranny.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clutch Pedal Pressure and Smelly Clutch
    By race5050 in forum Manual Transmission
    Replies: 1
    Last Post: 01-06-2010, 06:37 PM
  2. clutch pedal :gone:
    By IZNUTHN in forum Manual Transmission
    Replies: 8
    Last Post: 10-15-2008, 03:31 PM
  3. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 2
    Last Post: 09-22-2007, 09:51 PM
  4. Light Clutch Pedal (New Clutch)
    By Rhinohuey in forum Manual Transmission
    Replies: 5
    Last Post: 09-14-2007, 03:41 PM
  5. Fading Clutch Pedal with new clutch
    By mrbob2 in forum Manual Transmission
    Replies: 2
    Last Post: 08-17-2007, 06:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •